Closed Bug 610954 Opened 9 years ago Closed 9 years ago

"ASSERTION: aFrame should be first continuation" with CSS filter

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b8

People

(Reporter: jruderman, Assigned: dholbert)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(3 files)

Attached file testcase
###!!! ASSERTION: aFrame should be first continuation: '!aFrame->GetPrevContinuation()', file layout/svg/base/src/nsSVGEffects.cpp, line 510

Regression from within the last few hours.
Attached file stack trace
Most likely a regression from bug 587336.   I'll investigate in the morning.
Blocks: 587336
Looks like that patch should be using firstFrame rather than aFrame as the original code was.
Attached patch fixSplinter Review
oops! That's indeed a typo in the patch -- good catch!  Based on the stack that Jesse attached, that's exactly the problem here.

Sorry about that -- here's the fix.  I've confirmed locally that this fixes the assertion.
Attachment #489459 - Flags: review?(roc)
Assignee: nobody → dholbert
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 489459 [details] [diff] [review]
fix

Stealing review as I've already looked at this.
Attachment #489459 - Flags: review?(roc) → review+
Comment on attachment 489459 [details] [diff] [review]
fix

Thanks! Requesting landing approval -- just a typo fix on a line of code changed in bug 587336. (copy/paste fail when moving some code out of a helper function & into the caller.)  Assertion crashtest included.
Attachment #489459 - Flags: approval2.0?
Attachment #489459 - Flags: approval2.0? → approval2.0+
Landed: http://hg.mozilla.org/mozilla-central/rev/9b0f3c558494
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.