If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

A problem with opacity and link text

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Rafael, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

754 bytes, text/html
Details
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.44 Safari/534.7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

If the page has more than one HTML element with opacity set, the text shown in the page  

Reproducible: Always

Steps to Reproduce:
1. Create a page with some links like <a href="#" style="color: black; opacity: 0.4;">This is a link with opacity X</a>, but with the content text different for each link (10 links should be fine)
2. Open the page an click on the links to force the page to be rendered again
3. 
Actual Results:  
The text on some links are replaced by the text from other links

Expected Results:  
The text should remain the original ones

The problem only occurs on Windows 7
(Reporter)

Updated

7 years ago
Component: General → General
Product: Firefox → Add-on SDK
Summary: HTML element with style attribute opacity less than 1 are rendered incorrectly → Please remove this bug
Target Milestone: --- → --

Updated

7 years ago
Component: General → General
Product: Add-on SDK → Firefox
Summary: Please remove this bug → A problem with opacity and link text
Target Milestone: -- → ---
Version: unspecified → Trunk

Comment 1

7 years ago
Created attachment 489867 [details]
testcase

Can't reproduce in attached testcase built from str on following builds:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre

Rafael: can you reproduce it with the testcase?
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre

Can't reproduce, although I've seen something similar with iframe pages. 
Cork's page is more than sufficient so I will not post mine. 

Setting to WFM for the moment, if anyone should confirm this, please change to NEW.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.