use interCaps in nsIFindComponent.idl

VERIFIED FIXED

Status

SeaMonkey
Search
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Peter ``jag'' Annema, Assigned: Peter ``jag'' Annema)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
nsIFindComponent.idl currently uses InterCaps, going against style standards and
whatnot. Easily changed since this will (or should!) have no effect on C++ code,
and there's only one usage currently in js code (FindNext in finddialog.js).

Changing this because I'm moving some of that C++ code over to js code and
InterCaps looks rather out of place ;-)
(Assignee)

Comment 1

18 years ago
Created attachment 19665 [details] [diff] [review]
[patch] interCaps, remove obsolete dependancy on nsIWebShell in nsISearchContext, fix finddialog.js
(Assignee)

Comment 2

18 years ago
Seth: I cc'ed you, iirc you offered to r= this patch?
Status: NEW → ASSIGNED
(Assignee)

Comment 3

18 years ago
smfr: or maybe you offered to review this patch...

My apologies to the one who isn't the one. May I have a review from the one? :-)

Also, who should I ask to a= this?
r=sspitzer

looks good to me.  sfraser would be a good sr=, since I see his name all over
the Find code.  (him and law).

Comment 5

18 years ago
Looks good to me, also; that could pass for owner approval, I suppose.  BTW, I
searched (via LXR) all the .js files for each of the method names in question
and the one you fixed was indeed the only one I could find (in case anybody else
wonders about that).

Comment 6

18 years ago
sr=sfraser
(Assignee)

Comment 7

18 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.