[OSX 3.6.12] AJAX queries eventually seem to crash or get cached when using the same browser all day.

RESOLVED INCOMPLETE

Status

()

--
minor
RESOLVED INCOMPLETE
8 years ago
3 years ago

People

(Reporter: eanbowman, Unassigned)

Tracking

3.6 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.44 Safari/534.7
Build Identifier: 3.6.12

When browsing a page which loads bits in using jQuery AJAX queries, I've noticed that eventually the queries just stop grabbing new information.

For example, today I was working on a page which submitted JSON encoded arrays to an API which handled them and sent back another JSON encoded array.

This was working all day, but lo and behold when I walk over to a co-worker to have them look over my work at my desk by the time I came back Firefox had done its magic.

Every AJAX POST returned as 'Failed to load <page>...' (when viewed in Firebug) and the actual data didn't come back to my javascript either.

This seems to happen when I use the same browser window all day. It just eventually stops grabbing new AJAX queries until I close Firefox completely and re-load it.

This has happened a few times with a few different applications now. Sometimes it's Flash sending the JSON and getting nothing back and sometimes it's jQuery.

I'm pretty sure it's a bug with the MacOS version of the browser because with the same content I don't have an issue in Windows or Linux distros.

Thanks for taking the time to read my bug.


Reproducible: Sometimes

Steps to Reproduce:
1. Open browser and use an application which loads a lot of data using AJAX.
2. Wait all day while doing so.
3. Eventually you should stop getting new results from your AJAX requests.
Actual Results:  
Sometimes the browser stops loading new data and I have to close it to get it to behave properly again.

Expected Results:  
AJAX queries should always return new info considering the server is always returning 200 (new data, not a non-changed condition).
(Reporter)

Comment 1

8 years ago
Oh, in my example I say Firebug shows a failed to load condition but sometimes it just keeps returning the same data as the last AJAX call that worked.

Basically it ends up seeming like the call is cached sometimes, and others it's a Failed to load X condition.

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 2

4 years ago
p0larity, 
Does this still reproduce for you when using a current version?
Can you supply a testcase?
Flags: needinfo?(eanbowman)
Whiteboard: [closeme 2014-06-21]

Updated

4 years ago
Keywords: testcase-wanted
(Reporter)

Comment 3

4 years ago
Steps to reproduce are listed in the actual bug ticket.

I no longer have a MacOS system to test with.

I bet by now this has been fixed. If nobody else is complaining about lost AJAX queries after a certain amount of time I think you can safely close this bug.
Flags: needinfo?(eanbowman)

Comment 4

4 years ago
Resolved per whiteboard and Comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2014-06-21]
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.