Last Comment Bug 611129 - Quicksearch fails in 3.6.3 if List::MoreUtils is not installed
: Quicksearch fails in 3.6.3 if List::MoreUtils is not installed
Status: RESOLVED FIXED
: regression
Product: Bugzilla
Classification: Server Software
Component: Query/Bug List (show other bugs)
: 3.6.3
: All All
: -- major (vote)
: Bugzilla 3.6
Assigned To: Frédéric Buclin
: default-qa
:
Mentors:
: 625020 (view as bug list)
Depends on: 585028
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-10 14:37 PST by Frédéric Buclin
Modified: 2011-01-12 04:41 PST (History)
2 users (show)
mkanat: approval3.6+
LpSolit: blocking3.6.4+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch for 3.6.3, v1 (911 bytes, patch)
2010-11-10 15:08 PST, Frédéric Buclin
mkanat: review+
Details | Diff | Splinter Review

Description Frédéric Buclin 2010-11-10 14:37:19 PST
While fixing bug 585028, I applied the patch to all branches, assuming it was fine to use List::MoreUtils in all cases. But checksetup.pl only requires this module in Bugzilla 4.0 and newer, not in 3.6. This means that those who don't have this module installed now get an error everytime Bugzilla::Search::Quicksearch is called, when upgrading from 3.6.2 to 3.6.3.

I needed this module to use the 'firstidx' subroutine. For 3.6.x, we have to use something else.
Comment 1 Max Kanat-Alexander 2010-11-10 14:53:02 PST
Oh, yeah, use lsearch for 3.6.x.
Comment 2 Frédéric Buclin 2010-11-10 15:08:29 PST
Created attachment 489646 [details] [diff] [review]
patch for 3.6.3, v1
Comment 3 Max Kanat-Alexander 2010-11-10 15:11:30 PST
Comment on attachment 489646 [details] [diff] [review]
patch for 3.6.3, v1

Looks good to me. :-)
Comment 4 Frédéric Buclin 2010-11-10 15:45:06 PST
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified Bugzilla/Search/Quicksearch.pm
Committed revision 7206.
Comment 5 Frédéric Buclin 2011-01-12 04:41:43 PST
*** Bug 625020 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.