Quicksearch fails in 3.6.3 if List::MoreUtils is not installed

RESOLVED FIXED in Bugzilla 3.6

Status

()

defect
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: LpSolit, Assigned: LpSolit)

Tracking

({regression})

Dependency tree / graph
Bug Flags:
approval3.6 +
blocking3.6.4 +

Details

Attachments

(1 attachment)

Assignee

Description

9 years ago
While fixing bug 585028, I applied the patch to all branches, assuming it was fine to use List::MoreUtils in all cases. But checksetup.pl only requires this module in Bugzilla 4.0 and newer, not in 3.6. This means that those who don't have this module installed now get an error everytime Bugzilla::Search::Quicksearch is called, when upgrading from 3.6.2 to 3.6.3.

I needed this module to use the 'firstidx' subroutine. For 3.6.x, we have to use something else.
Flags: blocking3.6.4+
Oh, yeah, use lsearch for 3.6.x.
Assignee

Comment 2

9 years ago
Assignee: query-and-buglist → LpSolit
Status: NEW → ASSIGNED
Attachment #489646 - Flags: review?(mkanat)
Comment on attachment 489646 [details] [diff] [review]
patch for 3.6.3, v1

Looks good to me. :-)
Attachment #489646 - Flags: review?(mkanat) → review+

Updated

9 years ago
Flags: approval3.6+
Assignee

Comment 4

9 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified Bugzilla/Search/Quicksearch.pm
Committed revision 7206.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Assignee

Updated

9 years ago
Duplicate of this bug: 625020
You need to log in before you can comment on or make changes to this bug.