Cannot start cs localizatoin with the attached prefs.js (4 problematic lines isolated)

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Matěj Cepl, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 489628 [details]
failing prefs.js

I normally use firefox 3.6.12 (from Fedora package 
firefox-3.6.12-1.fc14.x86_64), when I tried Firefox 4.0b7 (from URL above) I get only error window with this text:

Chyba parsování XML: Nedefinovaná entita
Adresa: chrome://browser/content/browser.xul
Číslo řádku 232, sloupec 5:    <key id="key_openAddons" key="&addons.commandkey;" command="Tools:Addons" modifiers="accel,shift"/>
----^

(that's in English:
Error in parsing XML: Undefined entity
Address: chrome://browser/content/browser.xul
Line no. 232, col. 5: ....
)

When trying en_US version I have no problems. By the power of elimination I've got to be able to reproduce this reliably by putting the attached prefs.js to the profile.

By further elimination I've got to these four lines.

user_pref("extensions.blocklist.pingCount", 1);
user_pref("extensions.bootstrappedAddons", "{}");
user_pref("extensions.checkCompatibility.4.0b", false);
user_pref("extensions.databaseSchema", 3);

When I remove all of them, then a Czech Firefox 4.0b7 starts without problems. When I remove just one at a time, it doesn't (gives the above shown error). Not sure combination of which makes Firefox working.
It could be related to bug 602577
Best guess is that there is a locale pack installed on your system somewhere that doesn't have the entities needed, removing extensions.checkCompatibility.4.0b would make sure Firefox didn't try to load it making the problem go away.

Can you still reproduce this? If so please attach copies of extensions.sqlite, extensions.ini, extensions.log and prefs.js as they exist after exiting the broken Firefox.
If I remember correctly, there was a pref for a en-ZW dictionary(?) in the list of user prefs Matej showed us.
(Reporter)

Comment 4

7 years ago
Created attachment 489785 [details]
zip -9vT before.zip ueq16d3x.gnomeUser/extensions.{sqlite,ini,log} ueq16d3x.gnomeUser/prefs.js

Requested files before running FF4 on the profile.
(Reporter)

Comment 5

7 years ago
Created attachment 489786 [details]
zip -9vT after.zip ueq16d3x.gnomeUser/extensions.{sqlite,ini,log} ueq16d3x.gnomeUser/prefs.js

The same files after running (failing) firefox4
(Reporter)

Comment 6

7 years ago
And yes, removing

user_pref("extensions.checkCompatibility.4.0b", false);
user_pref("extensions.databaseSchema", 3);

made firefox 4.0b7 working again with this profile.
(Reporter)

Comment 7

7 years ago
And concerning my dictionaries ("celkem" is "total" in Czech):

jakoubek:firefox $ ls -lR ~/.mozilla/firefox/ueq16d3x.gnomeUser/extensions/
/home/matej/.mozilla/firefox/ueq16d3x.gnomeUser/extensions/:
celkem 0
jakoubek:firefox $ 

and

jakoubek:firefox $ ls ~/.mozilla/extensions/*/lang*
/home/matej/.mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/langpack-bn-IN@firefox.mozilla.org:

/home/matej/.mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/langpack-cs@firefox.mozilla.org:
chrome  chrome.manifest  install.rdf

/home/matej/.mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/langpack-te@firefox.mozilla.org:

/home/matej/.mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/langpack-cs@thunderbird.mozilla.org:
defaults  chrome  chrome.manifest  install.rdf
jakoubek:firefox $ 

and

jakoubek:~ $ ls -lR /usr/lib*/mozilla/extensions/\{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}/
/usr/lib64/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/:
celkem 0
jakoubek:~ $
As I suspected you have a cs locale pack installed in your profile that isn't compatible with Firefox 4b7. When you disable compatibility checking the local pack gets used and anywhere that tries to use strings that it doesn't have will be broken, in this case the main browser window is missing some strings.

You will either need to run with compatibility checking enabled, or uninstall or disable the locale pack in order to use 4b7.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> As I suspected you have a cs locale pack installed in your profile that isn't
> compatible with Firefox 4b7. When you disable compatibility checking the local
> pack gets used and anywhere that tries to use strings that it doesn't have will
> be broken, in this case the main browser window is missing some strings.
> 
> You will either need to run with compatibility checking enabled, or uninstall
> or disable the locale pack in order to use 4b7.

This doesn't feel like INVALID to me. I have had installed official language extension pack from the official Mozilla repository, and that should break Firefox? And when it breaks it, the only error message I get is nonsense about missing entity in XML?

I am sorry, but this is not INVALID. If you are not able to maintain compatibility with your own extensions, could you at least please give me an error message explaining me what's going on and what should I do?

Thank you.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(In reply to comment #9)
> (In reply to comment #8)
> > As I suspected you have a cs locale pack installed in your profile that isn't
> > compatible with Firefox 4b7. When you disable compatibility checking the local
> > pack gets used and anywhere that tries to use strings that it doesn't have will
> > be broken, in this case the main browser window is missing some strings.
> > 
> > You will either need to run with compatibility checking enabled, or uninstall
> > or disable the locale pack in order to use 4b7.
> 
> This doesn't feel like INVALID to me. I have had installed official language
> extension pack from the official Mozilla repository, and that should break
> Firefox? And when it breaks it, the only error message I get is nonsense about
> missing entity in XML?

Yes it is from Mozilla but it is also explicitly marked in the package as only compatible with Firefox 3.6. You have chosen to disable compatibility checking in Firefox, an option that is not intended for end users who don't understand the implications of what they're doing because add-ons that aren't compatible with your version of Firefox can make Firefox unusable, as you've seen.

You would probably find that installing the Firefox 4b7 version of the language pack works (http://releases.mozilla.org/pub/mozilla.org/firefox/releases/4.0b7/linux-i686/xpi/cs.xpi) however that is only marked compatible with Firefox 4b7 and probably wouldn't work with Firefox 3.6

Yes in some cases we can improve error messages for breakages but it generally isn't worth our time to cover cases caused by add-ons that aren't meant to be enabled anyway.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> You have chosen to disable compatibility checking
> in Firefox, an option that is not intended for end users who don't understand
> the implications of what they're doing because add-ons that aren't compatible
> with your version of Firefox can make Firefox unusable, as you've seen.

OK, I am sorry I missed this point. Apparently I am not worthy of being allowed to switch off that compatiblity check ;).
You need to log in before you can comment on or make changes to this bug.