Status

mozilla.org
MozillaBuild
RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: Wan-Teh Chang, Assigned: khuey)

Tracking

Details

(Reporter)

Description

8 years ago
The cvs command in MozillaBuild 1.5.1 is version 1.11.
Please upgrade it to the latest version, CVS 1.12.13.

I attached cvs.exe of CVS 1.12.13 and dependent DLLs to
bug 589111.  See bug 589111 comment 12 if you want to
download them yourself.

I can do the work if you tell me how to check out the
MozillaBuild sources.
hg clone http://hg.mozilla.org/mozilla-build <dest>
http://hg.mozilla.org/mozilla-build/rev/5b1a21855519

Wan-Teh, if you could test that the CVS in the build at http://people.mozilla.org/~khuey/MozillaBuildSetup1.6rc.exe meets your needs it would be appreciated.
Assignee: ted.mielczarek → khuey
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

7 years ago
khuey: it doesn't work.  Here is the transcript:

$ cvs -v

Concurrent Versions System (CVS) 1.12.13 (client/server)

Copyright (C) 2005 Free Software Foundation, Inc.

Senior active maintainers include Larry Jones, Derek R. Price,
and Mark D. Baushke.  Please see the AUTHORS and README files from the CVS
distribution kit for a complete list of contributors and copyrights.

CVS may be copied only under the terms of the GNU General Public License,
a copy of which can be found with the CVS distribution kit.

Specify the --help option for further information about CVS

Wan-Teh Chang@PHENOM2-PC /d/tmp
$ export CVSROOT=:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot

Wan-Teh Chang@PHENOM2-PC /d/tmp
$ cvs login
cvs [login aborted]: cannot get working directory: No such file or directory

Wan-Teh Chang@PHENOM2-PC /d/tmp
$ cvs -q co -A mozilla/nsprpub
cvs [checkout aborted]: cannot get working directory: No such file or directory
Ok, thanks for taking a look.  I'll dig in and see what's going wrong.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Unfortunately I'm going to bump the CVS upgrade from this release so that I can get a modern mercurial version to people.  I'll revisit this for 1.7.
No longer blocks: 631910
Blocks: 791486
Duplicate of this bug: 795503
NSS/NSPR live on hg these days. While I don't intend to remove CVS from MozillaBuild (yet), is there any reason to update it at this point?
Flags: needinfo?(wtc)
(Reporter)

Comment 8

4 years ago
We can mark this bug WONTFIX.

I don't need to use CVS from MozillaBuild right now because the NSPR and
NSS source code has migrated to Mercurial.

I just tested the CVS (still at version 1.11) from MozillaBuild 1.9.0.
I can still check out old NSPR and NSS source code from CVS without any
warnings.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago4 years ago
Flags: needinfo?(wtc)
Resolution: --- → WONTFIX
No longer blocks: 791486
You need to log in before you can comment on or make changes to this bug.