No music in Biolab disaster

RESOLVED DUPLICATE of bug 610627

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 610627
7 years ago
7 years ago

People

(Reporter: panzi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101110 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101110 Firefox/4.0b8pre

Since a few nightlies there is no music in the HTML 5 game Biolab Disaster anymore. Other sound effects are still there. (Chrome still plays the music, just to verify that it isn't Biolabs fault.)

Reproducible: Always

Steps to Reproduce:
1. visit url and hit x or c
Actual Results:  
No music playing

Expected Results:  
Music playing
wfm with  Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre SeaMonkey/2.1b2pre

clear the disk cache and try it again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610627
(Reporter)

Comment 2

7 years ago
The mime type is "audio/ogg", all the other sounds are played and even Firefox 3.6 plays the music... I just figured there might be the wrong data (with wrong mime type) in the cache so I deleted the cache, offline storage and cookies and now the music works again. So sorry for the bogus bug.
The website served the file with a wrong mime type for a short time.
You visited the game during this time and the file with the wrong mime-type got stored in your browser disk cache. The file didn't expire in the cache and that is the reason why it didn't start to work again after the server configuration got fixed.

Deleting the Disk cache is enough, cookies and offline storage doesn't matter in this case.
You need to log in before you can comment on or make changes to this bug.