High CPU usage when loading a list in the Versions extension using d2d

RESOLVED DUPLICATE of bug 588271

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 588271
8 years ago
6 years ago

People

(Reporter: Adam, Unassigned)

Tracking

({perf, regression})

Trunk
x86_64
Windows 7
perf, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

When hardware acceleration is on, upon launching a scan in the Versions extension, Cpu goes up to about 50%, list loads very slow and Firefox becomes unresponsive until the list is done loading.
The above does not happen with hardware acceleration off.

Reproducible: Always

Steps to Reproduce:
1. Install the Versions extension.
2. Create a list of about 50+ entries.
3. Turn on hardware acceleration.
4. Launch a scan from the add-on bar icon.
Actual Results:  
High CPU usage and general unresponsiveness of firefox.

Expected Results:  
Load the list in a few seconds, not hanging firefox.
Please post the graphic section from about:support
Component: Extension Compatibility → Graphics
Product: Firefox → Core
QA Contact: extension.compatibility → thebes
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
There you go - http://img5.imageshack.us/img5/7311/graphicsl.png
Thanks.
Adam, which extension is "Versions"?  I can't seem to find anything called that on addons.mozilla.org.

How does one create that list of 50+ entries?

Something worth checking:  Is the problem gone if you disable D2D but leave layers acceleration?  This could be bug 593812 if so....
(Reporter)

Comment 4

8 years ago
Hello Boris,
The extension in mention is https://addons.mozilla.org/en-US/firefox/addon/3830/

The list is the list that is used by the extension to detect changes in webpages, it is located in the profile folder under \Versions, specifically my list can be found in http://www.text-upload.com/read.php?id=25170&c=9504310 , just copy and paste into a new .list file.

As for your offer, I set "gfx.direct2d.disabled" to true and made sure "layers.accelerate-all" is set to true as well.
Suppose this is what you meant, than the problem is indeed gone in that case.

Thanks, Adam.

PS. for convenience sake:

  Graphics

        Adapter Description
        ATI Mobility Radeon HD 4500/5100 Series

        Vendor ID
        1002

        Device ID
        9553

        Adapter RAM
        512

        Adapter Drivers
        aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.782.0.0

        Driver Date
        9-28-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Windows
      1/1 Direct3D 10
> I set "gfx.direct2d.disabled" to true and made sure
> "layers.accelerate-all" is set to true as well.

Yep, that's what I wanted.  Just didn't recall the pref names.

> https://addons.mozilla.org/en-US/firefox/addon/3830/

Hmm.  This doesn't seem to use a tree...
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Depends on: 593812
Ever confirmed: true
Keywords: regression
Summary: High CPU usage when loading a list in the Versions extension using hardware acceleration → High CPU usage when loading a list in the Versions extension using d2d

Comment 6

8 years ago
(In reply to comment #5)
> Hmm.  This doesn't seem to use a tree...

But the widgets it creates use a lot -moz-border-colors rules, which Bas identified as the main cause of bug 593812.
(See skin/wfx_versions_custom.css)

I can reproduce this using the original XPI.
I furthermore tried removing all the -moz-border-colors stuff, with the result that the thing loaded much much faster.
So I guess this is indeed very similar to bug 593812, if not entirely the same.
(Reporter)

Comment 7

8 years ago
Just a quick note, when loading the exact same list for editing purposes, I experience no lag at all, everything runs smooth as it should be.

This is done by opening the extension options window, clicking the edit button in the bottom left and edit again.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588271
blocking2.0: ? → betaN+
Keywords: perf
You need to log in before you can comment on or make changes to this bug.