If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Accelerate the alipay plugin audit

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Plugins
--
major
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: xuan xie, Assigned: jorgev)

Tracking

Q4 2010
x86
Windows 7

Details

(Reporter)

Description

7 years ago
alipay.com is a third-party payment solution like paypal in China. It has more than 1 billion active users and play a vital role in Chinese e-commerce activity. However Its safety did not pass mozilla's audit.  When alipay update their plugin, it would lead to an enormous inconvenience among Chinese user. So please accelerate the alipay plugin audit.
(Reporter)

Comment 1

7 years ago
the url of alipay plugin

https://addons.mozilla.org/zh-CN/firefox/addon/6707/

Comment 2

7 years ago
We have got request from Alipay many times, please help on accelerate the review process of this addon. 
Alipay might stop to support the older version of this addon very soon. User will not going to have this addon upgrated if they do not know to come to our AMO site and install it manually.
Severity: normal → major
Component: Extension Compatibility → Plugins
Product: Firefox → addons.mozilla.org
QA Contact: extension.compatibility → plugin-listings
Target Milestone: --- → Q4 2010
Version: unspecified → 3.0
Assignee: nobody → jorge
(Assignee)

Comment 3

7 years ago
The Alipay extension is just a wrapper for an NPAPI plugin. Our policies about these kinds of add-ons is to reject them right away, because the only accepted way to update plugins is through the Plugin Finder Service, which unfortunately at the moment is quite insufficient for Alipay's needs.

Have they considered distributing the add-on on their site and using their own update URL? I don't think their users would have a hard time allowing the site to install an add-on, and it's probably less weird than sending them to AMO.

Comment 4

7 years ago
Hi Jorge, Thanks for your speedy response.
1. We have also opened a bug about the request for applying  "Plug-in Finder Service" https://bugzilla.mozilla.org/show_bug.cgi?id=611253
Not sure what is the requirement for making it possible. Since Firefox in China is encountering enormous problem in online banking system. Supporting Alipay becomes more critical for us to retain users.

2. please see https://bugzilla.mozilla.org/show_bug.cgi?id=611227
They also tried to build this plug-in on their own server, but somehow we are not able to make it working on plug-in update. Our engineer Xuan also tried this, but he did not succeed either, so he opened a bug looking to help.

So at the end they turn to AMO.
(Assignee)

Comment 5

7 years ago
(In reply to comment #4)
> Hi Jorge, Thanks for your speedy response.
> 1. We have also opened a bug about the request for applying  "Plug-in Finder
> Service" https://bugzilla.mozilla.org/show_bug.cgi?id=611253
> Not sure what is the requirement for making it possible. Since Firefox in China
> is encountering enormous problem in online banking system. Supporting Alipay
> becomes more critical for us to retain users.

I don't know if that will be possible. The PFS is very limited at the moment, and only a handful of plugins are included.

> 2. please see https://bugzilla.mozilla.org/show_bug.cgi?id=611227
> They also tried to build this plug-in on their own server, but somehow we are
> not able to make it working on plug-in update. Our engineer Xuan also tried
> this, but he did not succeed either, so he opened a bug looking to help.

This is more interesting. I'd like to try to determine the cause of these problems they're having, because as far as I know it shouldn't be a problem to update the XPI using their own servers. I've added a comment on bug 611227 to try to get to the root of the problem.

Comment 6

7 years ago
Hi Jorge,
Xuan has made the Alipay plugin updated successfully. 
He closed the bug 611227.
In this case we can also close the current bug for AMO reviewing. What do you think ?
Thank you for your help.
Hong
(Assignee)

Comment 7

7 years ago
WONTFIX, then. I'm glad to hear it's working for you now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.