If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 4.0b7 crash in [@ fillInCell ]

RESOLVED WORKSFORME

Status

()

Toolkit
Storage
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(crash signature)

(Reporter)

Description

7 years ago
Seen while reviewing crash stats for B7. Currently the #31 top crash in B7. http://tinyurl.com/375hccl links to the current crashes.

Frame 	Module 	Signature [Expand] 	Source
0 	mozsqlite3.dll 	fillInCell 	
1 	mozsqlite3.dll 	winMutexLeave 	db/sqlite3/src/sqlite3.c:17058
2 	mozsqlite3.dll 	saveCursorPosition 	
3 	mozsqlite3.dll 	sqlite3BtreeInsert 	db/sqlite3/src/sqlite3.c:51187
4 	mozsqlite3.dll 	moveToChild 	db/sqlite3/src/sqlite3.c:48589
5 	mozsqlite3.dll 	sqlite3WalEndReadTransaction 	db/sqlite3/src/sqlite3.c:42878
6 	mozsqlite3.dll 	sqlite3VdbeHalt 	db/sqlite3/src/sqlite3.c:56596

Comment 1

7 years ago
The stack trace does not seem to make much sense.  

(1) sqlite3WalEndReadTransaction never calls moveToChild, sqlite3BtreeInsert, saveCursorPosition, winMutexLeave, or fillInCell, either directly or indirectly.

(2) moveToChild never calls sqlite3BtreeInsert, directly or indirectly.

(3) saveCursorPosition never calls winMutexLeave, directly or indirectly.

(4) winMutexLeave is a thin wrapper around the win32 LeaveCriticalSection system call and never invokes anything else, and especially not fullInCell.

Given that the stack trace makes no sense, are there any suggestions on how we can trouble-shoot this?

Updated

7 years ago
Duplicate of this bug: 612084
(Reporter)

Comment 3

7 years ago
One comment indicated that they started crashing after plug-in compatability.
Summary: Firefox 4.0b7 crash in [@ fillInCell ] → Firefox 4.0b7 crash in [@ fillInCell]
Blocking+ for investigation (dupe had the request).
blocking2.0: --- → betaN+

Updated

7 years ago
Component: Places → Storage
QA Contact: places → storage
(Reporter)

Comment 5

7 years ago
I did a quick check in crash-stats and there is only one instance of this on the trunk despite the fact it there were a fair number of crashes in Beta 7. I also see a few reports from 3.5.x and 3.6.x. Unfortunately there are no useful comments in all of the reports. Probably will have to wait until B8 ships to see how this plays out in that release as far as the numbers go.

Updated

7 years ago
Summary: Firefox 4.0b7 crash in [@ fillInCell] → Firefox 4.0b7 crash in [@ fillInCell ]

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Crash Signature: [@ fillInCell ]
You need to log in before you can comment on or make changes to this bug.