Text in text area only shows small portion in upper left

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Drew Stephens, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

When adding a workout to http://21-15-9.com (account required, but it's a pretty standard Rails app), text entered into the Notes field only shows up as a couple of half-height characters in the upper left of the text area.  You can enter text fairly blindly, and it works, you just can't see much of what you are typing.

The markup for the textarea is:
    <textarea class="workout_description" cols="40" id="workout_notes" name="workout[notes]" rows="20" style="font-size: 12px; font-weight: x; border: 1px #CCC solid; padding: 2px; width: 500px; height: 80px;">

I used a new Firefox profile to confirm this.

Reproducible: Always

Steps to Reproduce:
1. Create a new workout on http://21-15-9.com
2. Type in the Notes field
Actual Results:  
Text entered in the Notes field only shows up as a couple of half-characters in the upper left corner.

Expected Results:  
The text entered fills the text area.
(Reporter)

Comment 1

8 years ago
Created attachment 489858 [details]
"fo" typed in the offending textarea
Does the Bug happen if you put the Code of Comment 0 in a single Testcase?
Since there's no Issue for me on WinXP - neither on Trunk nor on Beta 6.
(Reporter)

Comment 3

8 years ago
Hmm, indeed I cannot reproduce it with just that textarea markup.  I will investigate further with the page's CSS as well.
OS: Mac OS X → Windows 7
Check what's actually in the DOM?  Is it actually using a <textarea>, or a contenteditable iframe once all the scripts are done running?  DOM Inspector or Firebug should be able to tell you what's actually there...
Severity: major → normal
Keywords: testcase-wanted
Drew, any update on this?
(Reporter)

Comment 6

7 years ago
I just tried to reproduce this in the exact manner I described and couldn't—I'm happy to call it fixed sometime between b6 and now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Keywords: testcase-wanted
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.