Become an MDN member link is broken

RESOLVED INVALID

Status

P2
normal
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: retornam, Unassigned)

Tracking

Details

(Whiteboard: u=user c=users p=, URL)

(Reporter)

Description

8 years ago
STR:
1) Visit https://developer-stage9.mozilla.org/en-US/
2) Click  the Become An MDN member link
3) The page refreshes to the homepage instead of bringing up a page for user to sign-up for an account
(Reporter)

Updated

8 years ago
Severity: normal → critical
Target Milestone: --- → 0.9.2

Comment 1

8 years ago
WFM.  Raymond:  Are you able to consistently reproduce?
(Reporter)

Comment 2

8 years ago
Yes. see the screencast below 
http://screencast.com/t/JYULGrQI
(In reply to comment #2)
I believe this is a corner case that requires more steps to reproduce.

I can't repro, but I believe I have in the past... Something like login via deki, go to homepage. Instead of Welcome back, it says login. Click Become a member, that pages sees that you are already logged in and redirects to the homepage.

Raymond, can you clear you cookies and try to repro? If this doesn't affect most users, I think we should punt, since SSO will fix these issues.
(Reporter)

Comment 4

8 years ago
I cleared  my cookies and was able to reproduce a  few times after though it was a bit random
(In reply to comment #4)
Can you reproduce this behavior in production or is this new with 0.9.2?
Bumping to SSO release.
Target Milestone: 0.9.2 → 0.9.3

Updated

8 years ago
Severity: critical → blocker

Updated

8 years ago
Duplicate of this bug: 623811

Comment 8

8 years ago
I reported this yesterday (see duplicate bug), but it's working for me today.
Whiteboard: 0.9.2.2
Target Milestone: 0.9.3 → 0.9.2
Assignee: nobody → lcrouch
Depends on: 624750
jay, can we bump this to the SSO (0.9.5) release since it's blocked and it should be fixed by SSO?

if so let's take off the 0.9.2.2 whiteboard status?
Target Milestone: 0.9.2 → 0.9.3

Comment 10

8 years ago
Yeah, let's work out this issue along with SSO.
Whiteboard: 0.9.2.2
Target Milestone: 0.9.3 → 0.9.5
Assignee: lcrouch → nobody
Severity: blocker → normal
Target Milestone: 0.9.5 → ---
OS: Windows 7 → All
Priority: -- → P2
Hardware: x86 → All
Whiteboard: u=user c=users p=
MDN site has new design and that link no longer exists.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Version: MDN → unspecified
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.