Possible race condition regarding static variable in singsign.cpp

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
18 years ago
10 years ago

People

(Reporter: morse, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
signsign.cpp uses a static variable si_UserHasBeenSelected to solve certain 
problems regarding the list of multiple users that is sometimes displayed when 
more than one login is saved for the same URL.  This could result in a race 
condition if two pages are loading simultaneously in two separate windows and 
both pages have login forms and there are more than one saved logins for each of 
the two pages.  It's probably very unlikely that this will ever happen, and 
certainly very difficult to give a set of instructions that will actually 
demonstrate the problem.
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Possible race condition regarding static variable in singsign.cpp → [z]Possible race condition regarding static variable in singsign.cpp
Target Milestone: --- → Future
How do you know a bad race is unlikely?  A frameset with two frames, each
containing text widgets, where the content of the two frames results in the
right combination of TCP segment boundaries, or just tag open/close relations,
to sink content in an interleaved fashion, could do it.  Cc'ing layout peers.

Does the [z] cybercrud mean "I want to mark this bug WONTFIX but I'm scared of
being criticized"?  Maybe the right answer is to use the Priority field as it
was intended to be used.

/be
(Reporter)

Updated

18 years ago
Summary: [z]Possible race condition regarding static variable in singsign.cpp → Possible race condition regarding static variable in singsign.cpp
Whiteboard: [z]
Netscape nav triage team: based on Steve Morse's pretriage recommendation, this 
is not a beta stopper.
Keywords: nsbeta1-
(Reporter)

Updated

18 years ago
Whiteboard: [z]
Reassigning to new module owner.
Assignee: morse → dveditz
Status: ASSIGNED → NEW
Product: Browser → Seamonkey
Assignee: dveditz → nobody
QA Contact: tpreston
Priority: P3 → --
Target Milestone: Future → ---

Comment 4

10 years ago
Obsoleted by Bug 390025 (Move to LoginManager and remove wallet from SeaMonkey)
Not using said file any more.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.