Site-specific data spread throughout despot

RESOLVED FIXED

Status

Webtools Graveyard
Despot
P3
enhancement
RESOLVED FIXED
18 years ago
2 years ago

People

(Reporter: Phil Schwan, Assigned: reed)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

18 years ago
Data such as maintainer, maintainer's email, Despot URL, and domain should be
split out into a separate config.pl

I *just* so happen to have a patch for that.
(Reporter)

Comment 1

18 years ago
Created attachment 19683 [details] [diff] [review]
The aforementioned config patch

Comment 2

18 years ago
Patch barfs on these diffs and won't apply them.  Can you generate another?

Comment 3

18 years ago
Mass re-assign of despot bugs to endico@mozilla.org, the new owner.  I'm
switching groups to go work on mozilla LDAP integration.

Comment 4

18 years ago
Another try at mass-reassigning my Despot bugs to endico.
Assignee: dmose → endico

Comment 5

16 years ago
Created attachment 86053 [details] [diff] [review]
attachment 19683 [details] [diff] [review] (which appears to be based on rev1.20/1.21) merged to tip
Attachment #19683 - Attachment is obsolete: true

Updated

16 years ago
Severity: minor → enhancement
Keywords: patch
QA Contact: matty → timeless
reassigning endico's Despot bugs to the default component owner
Assignee: endico → justdave
(Assignee)

Updated

12 years ago
QA Contact: timeless → despot
(Assignee)

Comment 7

12 years ago
*** Bug 322730 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

12 years ago
Created attachment 248341 [details] [diff] [review]
patch - v1

I took attachment 86053 [details] [diff] [review] and modified it to use the current config.pl format. Also, I used $secure_url instead of a hardcoded Despot URL. The config also contains the owners page URL, too.
Assignee: justdave → reed
Attachment #86053 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #248341 - Flags: review?(justdave)
Attachment #248341 - Flags: review?(justdave) → review+
(Assignee)

Comment 9

12 years ago
Checking in despot.cgi;
/cvsroot/mozilla/webtools/despot/despot.cgi,v  <--  despot.cgi
new revision: 1.53; previous revision: 1.52
done
Checking in config.pl.dist;
/cvsroot/mozilla/webtools/despot/config.pl.dist,v  <--  config.pl.dist
new revision: 1.2; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.