If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Cloud Services
Operations
--
major
RESOLVED DUPLICATE of bug 604131
7 years ago
7 years ago

People

(Reporter: telliott, Assigned: atoll)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Here are the steps for 1.5. Most of these are independent, so they can be done asyncronously (db changes before code changes, though!).

1) Alter the nodes db as described in Bug 599133. Update the rows in the db to fill in the new columns.

2) Alter the prod db to add a column ttl int(11). At this time, we can also drop that redundant index (and might want to consider indexing ttl for fast table deletes)

3) grab a copy of http://hg.mozilla.org/services/server-node-assignment/ somewhere in a build directory. 

[tarek, please add details on how to build and deploy this here]

Edit /etc/mozilla-services/syncnodes.cfg to point to the correct db and to create a secret. At this point, it should pass all the tests.

Add a line to the apache config to point at the wsgi file. (something like WSGIScriptAlias /nodeadmin /home/apache/server-node-assignment/syncnodes.wsgi) Make sure this has all the appropriate firewall protection.

4) Shut down a webserver. Update the weave-sync hg. You should see the 1.0 folder disappear and a 1.1 folder appear.

Edit the apache conf to point /1.0 at the new 1.1 folder instead. Add another line that points /1.1 at the new 1.1 folder.

Restart apache and bring the server back up.
(Reporter)

Comment 1

7 years ago
tarek: please add build data to step 2
I've added a Makefile. Not sure how you want to deploy this for the 1.5 push  

- If it's RPM-based we need to fix the current .spec and a few things in setup.py. (the current spec is broken.)

- If it's a raw install, "python setup.py install" will work - but there's a missing option in setup.py for the scripts to be installed.

I'll review the code and send you some suggestions. 

Last: since it's a new, independant distribution, its version should start at 0.1 maybe, but not 1.5.
(Reporter)

Comment 3

7 years ago
The spec is broken? It built the package fine when you were here. Did it change again?

Good point on the version.
(Reporter)

Comment 4

7 years ago
Version on node-assignment moved to 0.1. Spun out that into it's own bug, since maintenance of that can be done directly in the db, avoiding most python.
(Assignee)

Updated

7 years ago
Assignee: nobody → rsoderberg
Severity: normal → major
Summary: 1.5 push → push sync-server 1.5
(Assignee)

Comment 5

7 years ago
1.3 s/reg and 1.5 sync being prepared in weave-dev and weave-stage, QA request pending.

We are delaying node-assignment related work (copying constants to memcache, setting new values in available_nodes, web ui, related scripts) until after the 1.3 s/reg and 1.5 sync push is QA'd and in production.
Status: NEW → ASSIGNED
OS: Mac OS X → Windows 7
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604131
You need to log in before you can comment on or make changes to this bug.