If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[OOPP]Black rectangle appears behind Flash Object on www.punypng.com

RESOLVED DUPLICATE of bug 611698

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 611698
7 years ago
7 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
mozilla2.0
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
Created attachment 490008 [details]
reduced html

Build Identifier: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre ID:20101111042449

Black rectangle appears behind Flash Object on www.punypng.com

*This does not happens if I set dom.ipc.plugins.enabled to false.
*This does not happens on Firefox 3.6.x.

This may be related to Bug 607578 which was fixed by bug 596451 accidentally.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL ( http://www.punypng.com/ )

Actual Results:
 Black rectangle appears behind Flash Object

Expected Results:
 Black rectangle should NOT appear.
(Reporter)

Comment 1

7 years ago
Created attachment 490009 [details]
screenshot
(Reporter)

Updated

7 years ago
Blocks: 611698

Comment 2

7 years ago
Believe I'm seeing the same issue.

Was on this page:

http://www.dslreports.com/forum/r25071604-Password-Management.-What-s-recommended~start=20#25079926

Went to reply, & saw http://i56.tinypic.com/2f07z35.jpg (in SeaMonkey ) & http://i56.tinypic.com/xqg9oy.jpg (in FF).

I came up with a regression range between 20101110 & 20101111:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3cd4bdbfce3b&tochange=7e3e4c91c0f7

As you mention, setting dom.ipc.plugins.enabled to false does look to bypass the issue, as does running in -safe-mode.

> Callek	therube: fwiw: http://hg.mozilla.org/mozilla-central/rev/bdbef533364f (and the rest of its push) looks quite likely


My discussion of this should be able to be found (tomorrow) at: http://www.hirsch.sth.ac.at/~robert/thebot-logs/seamonkey-index.xml .  Should be the 2010-11-16 log (I suppose).

Comment 3

7 years ago
Created attachment 490811 [details]
plugincontainer needs work yet - as seen in SeaMonkey Trunk

plugincontainer needs work yet - as seen in SeaMonkey Trunk.

In this case, the plugin is in a frame.  Happens to be overlayed as shown, but it's look can change depending on positioning.  And it is actually an aberration, if you want to look at it that way.  Even Alice's black rectangle can be made to "disappear".

Comment 4

7 years ago
Created attachment 490812 [details]
screenshot - same results with Firefox

screenshot - same results with Firefox

Comment 5

7 years ago
(There are other Flash anomalies though not sure if they are this bug too, or can be fixed by whatever ends up fixing this bug, and are more typified by bugs like: Bug 612057 Bug 612154 Bug 612145 )

Comment 6

7 years ago
Perhaps even Bug 580159 & Bug 591020 are related.

Comment 7

7 years ago
This bug is also reproducible at http://www.telusmobility.com/en/BC/plans/ and I have also encountered it on engadget.com.

Do the following using Windows 7 and then Windows XP:
1. Start with a new profile
2. Disable hardware acceleration and restart (I'm not sure if this matters)
3. Visit: http://www.telusmobility.com/en/BC/plans/
4. If prompted to "Please select your province," choose "British Columbia"
5. In the absence of this bug, you should now see large headings that include: "Plans", "Clear Choice Voice & Data Plans", "Clear Choice Voice Plans", etc.
a) On Windows 7, note that flash background is black (it should be transparent)
b) On Windows XP, note that flash is completely white (it should have text)
6. Disable IPC plugins and try again.  Notice the page now looks like it should.

Compare with Goggle Chrome, Opera, and Internet Explorer, which all render the flash content correctly.

Regression pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1d1ff6b489&tochange=0f17e5f1eb01
Blocks: 596451
blocking2.0: --- → ?
Keywords: regression

Comment 8

7 years ago
I believe that this is a dup of bug 611698.

Comment 9

7 years ago
Yeah; gotta be.  Was hunting for that bug yesterday, but couldn't find it.  Thanks.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611698

Updated

7 years ago
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.