crash [@ nsTArray<mozilla::plugins::BrowserStreamChild::PendingData, nsTArrayDefaultAllocator>::Clear() ]

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
8 years ago
3 months ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(crash signature)

(Reporter)

Description

8 years ago
Build: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101111
Firefox/4.0b8pre

It is a new crash signature. Crashes first appeared with this build.
It is #9 top crasher in this build: 50 crashes/buildday.
It can be related to bug 611593.

Signature	nsTArray<mozilla::plugins::BrowserStreamChild::PendingData, nsTArrayDefaultAllocator>::Clear()
UUID	c5614407-555d-495d-9df4-6a4a82101112
Process Type	plugin Version: Filename: NPSWF32.dll
Time 	2010-11-12 01:58:01.43276
Uptime	184
Install Age	60402 seconds (16.8 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101111042449
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 6 model 22 stepping 1
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 01d3

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsTArray<mozilla::plugins::BrowserStreamChild::PendingData,nsTArrayDefaultAllocator>::Clear 	obj-firefox/dist/include/nsTArray.h:841
1 	xul.dll 	mozilla::plugins::BrowserStreamChild::Deliver 	dom/plugins/BrowserStreamChild.cpp:239
2 	xul.dll 	mozilla::plugins::PluginInstanceChild::AnswerNPP_Destroy 	dom/plugins/PluginInstanceChild.cpp:2961
3 	xul.dll 	mozilla::plugins::PPluginInstanceChild::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp:1681
4 	xul.dll 	mozilla::plugins::PPluginModuleChild::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginModuleChild.cpp:574
5 	xul.dll 	mozilla::ipc::RPCChannel::DispatchIncall 	ipc/glue/RPCChannel.cpp:517
6 	xul.dll 	mozilla::ipc::RPCChannel::Incall 	ipc/glue/RPCChannel.cpp:503
7 	xul.dll 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne 	ipc/glue/RPCChannel.cpp:434
8 	xul.dll 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:343
9 	xul.dll 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:351
10 	xul.dll 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:451
11 	xul.dll 	base::MessagePumpForUI::DoRunLoop 	ipc/chromium/src/base/message_pump_win.cc:213
12 	xul.dll 	base::MessagePumpWin::RunWithDispatcher 	ipc/chromium/src/base/message_pump_win.cc:52
13 	xul.dll 	base::MessagePumpWin::Run 	ipc/chromium/src/base/message_pump_win.h:78
14 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
15 	xul.dll 	MessageLoop::RunHandler 	
16 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
17 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp:506
18 	plugin-container.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:125
19 	plugin-container.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
20 	kernel32.dll 	BaseProcessStart 	

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1d1ff6b489&tochange=0f17e5f1eb01

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsTArray%3Cmozilla%3A%3Aplugins%3A%3ABrowserStreamChild%3A%3APendingData%2C%20nsTArrayDefaultAllocator%3E%3A%3AClear%28%29
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
12 crashes in the last week on the trunk.

Comment 2

8 years ago
Please renom if this is higher in beta8 builds.
blocking2.0: ? → -
Crash Signature: [@ nsTArray<mozilla::plugins::BrowserStreamChild::PendingData, nsTArrayDefaultAllocator>::Clear() ]

Comment 3

7 years ago
Only 2 on 7.0.1 in the past 4 weeks and a couple on 8.0. Pretty low volume. Certainly not a top crash so removing the keyword.
Keywords: topcrash

Updated

3 years ago
Crash Signature: [@ nsTArray<mozilla::plugins::BrowserStreamChild::PendingData, nsTArrayDefaultAllocator>::Clear() ] → [@ nsTArray<mozilla::plugins::BrowserStreamChild::PendingData, nsTArrayDefaultAllocator>::Clear() ] [@ nsTArray<T>::Clear ]
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.