iCal uses illegal SCHEDULE-AGENT parameter in ORGANIZER in iMiP confirmation

RESOLVED WONTFIX

Status

Calendar
Provider: CalDAV
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: tierlieb, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla.org/NONSGML Mozilla Calendar V1.1//EN

Our system, which uses ical4J as parser, just reported an error with an ical imip file we got. It is rather simple: You're using the parameter SCHEDULE-AGENT for the element ORGANIZER. ical4j doesn't like you because of that. 

And while I think it is just being bitchy, it is completely right from a standards viewpoint: RFC5545 does not allow this parameter. I went through the whole xBNF provided in the RFC and the only possibility would be that it is an IANA-registered token. And the list I found (http://www.iana.org/assignments/icalendar/icalendar.xhtml) does not contain it.

I'll provide a two-letter workaround for that: Prefix it with X- and you can still be friends with ical4j. Or use X-MOZ- like you use for element names. That is allowed by the RFC and ignored by ical4j.

P.S.: My condolences to the devs who do ical/imap. I'm the guy doing it at our company and I know: "Hell is other clients".

Reproducible: Always

Comment 1

7 years ago
SCHEDULE-AGENT seems to be part of CalDAV Scheduling Extensions to WebDAV RFC: 
http://tools.ietf.org/html/draft-desruisseaux-caldav-sched-09#section-10

Support was added with Bug 463392 by Simon.
Component: General → Provider: CalDAV
QA Contact: general → caldav-provider
Correct. Although a draft, SCHEDULE-AGENT falls under the category IANA registered token. ical4j should be a bit more forgiving, taking the possibility of such drafts into account.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.