Closed Bug 611652 Opened 9 years ago Closed 6 years ago

PNC Hover Dialog Background Error

Categories

(Core :: Layout, defect, minor)

x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: grenavitar, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre

When logged into the PNC the text on hover shows but the background does not follow behind all of the text.

Reproducible: Always
Attached image Screenshot of the error
Component: General → Layout
Product: Firefox → Core
Version: unspecified → Trunk
It works on 3.6.12 so it is a regression.
You can't find a open Site showing you Issue by any Chance?
Or do you want to search for a Range on your own?
QA Contact: general → layout
Fritz, given that we can't access the page in question, can you perhaps look up what does the DOM/style around that element looks like?
Sorry, I meant to get around to checking a regression range but didn't.  In the meantime they seem to have changed their code.  Looking through it, it's hard for me to parse since it's all JS and frames so it's difficult for me to track down where the code that renders that section is.
I also noticed that the same style works in Minefield but on the main customer page and not the account info page.  So, it might be an issues in their code that they changed.

I'm not sure why it'd have worked with 3.6 and not Minefield.  Maybe related to the drop down not rendering bug since Gecko started at 0 and not 1.
Here is the source of the site where I got the error but now get a different hover box.  It's a little opaque for me but with a walkthrough I can try (if you think this bug is still valid... it might not be... and if so, sorry for any time wasted.)
It's really hard to say, given that their code is changing... maybe they're partway through a site update and one of the browsers got partial stylesheets from the new version.  Maybe they're browser-sniffing.  Maybe they're relying on a 3.6 bug.  Maybe 4.0 has a bug.

Not really enough information here to tell those apart, unfortunately.  :(

Have you reported the issue to the bank?  I'd be curious to hear what they say about it (assuming it's not the usual useless "we don't support beta versions of browsers" without actually reading the problem description....)
Well, it's back... I can't say I understand how/why but I see the error again.

I've sent a message to PNC "Online Banking Support" linking to this bug and showing a screenshot.  Hopefully whoever gets those requests will know how to forward it.
Comment on attachment 490467 [details]
PNC as it renders now -- seems code changed.

It's back to how it was originally when I filed the bug.  I'm marking this obsolete.
Attachment #490467 - Attachment is obsolete: true
Fritz, if the Issue still happens for you, can you spoof Firefox' 4 User Agent String using "general.useragent.override" in about:config and turn it into a Firefox 3.6. User Agent String?
(In reply to comment #12)
> Fritz, if the Issue still happens for you, can you spoof Firefox' 4 User Agent
> String using "general.useragent.override" in about:config and turn it into a
> Firefox 3.6. User Agent String?

I set my string to "Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9" -- checked it on http://whatsmyuseragent.com/ -- but I still got the same error on the PNC website.
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/6882211c4a80
Note: not marking as fixed because fixed-in-tracemonkey is not present on the whiteboard.
Depends on: 632433
(A fix for bug 611653 was landed as http://hg.mozilla.org/tracemonkey/rev/6882211c4a80, mistakenly referring to this bug)
No longer depends on: 632433
Fritz, can you still repro the Issue against 4.0.1 or a Nightly?
(In reply to comment #16)
> Fritz, can you still repro the Issue against 4.0.1 or a Nightly?

Yes I can on the 2011-05-08 nightly.  It's still on the Account Activity page where you see the error and not on the Account List page even though it has the same type of hover dialog.
Hmmm, okay. Do you get any relevant Error Console Output by Chance? Did you report the Issue to the Bank's Support?
(In reply to comment #18)
> Hmmm, okay. Do you get any relevant Error Console Output by Chance? Did you
> report the Issue to the Bank's Support?

I did contact them and got a non-answer about passing it on in return.

Here is some Error Console messages from the page.  No idea if they're relevant:

Warning: Expected declaration but found '*'.  Skipped to next declaration.
Source File: https://www.onlinebanking.pnc.com/JavaScriptLib/dynamicjs/build/menu/assets/skins/sam/menu.css
Line: 7

Warning: Error in parsing value for 'filter'.  Declaration dropped.
Source File: https://www.onlinebanking.pnc.com/JavaScriptLib/dynamicjs/build/menu/assets/skins/sam/menu.css
Line: 7

Warning: Error in parsing value for 'cursor'.  Declaration dropped.
Source File: https://www.onlinebanking.pnc.com/JavaScriptLib/dynamicjs/build/menu/assets/skins/sam/menu.css
Line: 49

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: https://www.onlinebanking.pnc.com/css2/common.css
Line: 256

Warning: Expected end of value but found '10xp'.  Error in parsing value for 'padding'.  Declaration dropped.
Source File: https://www.onlinebanking.pnc.com/css2/common.css
Line: 1257
> Here is some Error Console messages from the page. 

Yeah, those don't look obviously related...
Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130801 Firefox/25.0

Couldn't reproduce with latest Nightly (Build ID: 20130801030223): when I hover over Privacy and Security in the upper right corner or the Lock Symbol on the bottom right in the URL from comment 21, I see no background issue.

Fritz, is this still an issue with latest builds?
Flags: needinfo?(grenavitar)
(In reply to Alexandra Lucinet [QA] from comment #22)
> Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130801 Firefox/25.0
> 
> Couldn't reproduce with latest Nightly (Build ID: 20130801030223): when I
> hover over Privacy and Security in the upper right corner or the Lock Symbol
> on the bottom right in the URL from comment 21, I see no background issue.
> 
> Fritz, is this still an issue with latest builds?

It works now in Aurora.
Flags: needinfo?(grenavitar)
Marking as Resolved WFM based on comment 22 and comment 23.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.