Updating the extension fires the welcome page

RESOLVED FIXED in 1.3

Status

Mozilla Labs Graveyard
Test Pilot
P1
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: tracy, Unassigned)

Tracking

Details

(Whiteboard: extension - TP addon only, needs-integration)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
I just got an update of the Test Pilot Extension from 1.0.1 to 1.0.3. on completion of the update, the welcome chrome://testpilot/content/welcome.html page was opened.  

I would expect that page only on first time installation experience. 

A "What's New" page might be more appropriate or nothing at all.

Updated

7 years ago
Whiteboard: extension - TP addon only

Updated

7 years ago
Priority: -- → P1
Target Milestone: --- → 1.2

Updated

7 years ago
Target Milestone: 1.2 → 1.3

Comment 1

7 years ago
Fixed in http://hg.mozilla.org/labs/testpilot/rev/b7dc5e2421b8  - welcome page now only opened once, on first run.

(This may also fix bug 651138 - we should see if that can still be duplicated after applying this patch.)
Whiteboard: extension - TP addon only → extension - TP addon only, needs-integration

Comment 2

7 years ago
Created attachment 533373 [details] [diff] [review]
Patch against mozilla-central fixing the problem
Attachment #533373 - Flags: review?(dtownsend)
Comment on attachment 533373 [details] [diff] [review]
Patch against mozilla-central fixing the problem

Review of attachment 533373 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #533373 - Flags: review?(dtownsend) → review+
Landed: http://hg.mozilla.org/mozilla-central/rev/1f0cac68a2cc

These files seem to have a lot of whitespace problems (tabs in particular). At some point we should clean those up

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Duplicate of this bug: 651138
(Assignee)

Updated

2 years ago
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.