Closed Bug 611753 Opened 9 years ago Closed 9 years ago

[Regression] typing in the filter field in about:config does not filter any of the preferences

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0b3+)

VERIFIED FIXED
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: nhirata, Assigned: mbrubeck)

References

Details

Attachments

(2 files)

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101112 Firefox/4.0b8pre Fennec/4.0b3pre (2nd spin)

1. go to about:config
2. type in "update" into the filter / search field 

Expected: the list will filter down to preferences that contain the word "update"
Actual: list does not change
Duplicate of this bug: 611800
Attached patch FixSplinter Review
For some reason we are not applying the correct binding here anymore. This fixes this for me on desktop. I'm still trying to dig to see what changed if we want a better fix.
Attachment #490234 - Flags: review?(mark.finkle)
The CSS binding for Matt's new textbox binding is taking precedence over the default search binding. If we take this patch, then any search textbox in the chrome UI will not support support context menus.

We need a new search textbox binding too?
Assignee: nobody → mbrubeck
tracking-fennec: --- → 2.0b3+
Attached patch alternate patchSplinter Review
This adds overrides for all of the textbox bindings.  (God, I hate how this works in XBL .)  It fixes the bug, although the context menu does not actually work in about:config (because we don't forward TapLong to content?).

I'm curious why my "textbox" binding overrode the platform "textbox[type=search]" binding, when the latter has higher specificity...
Attachment #490375 - Flags: review?(mark.finkle)
(In reply to comment #4)
> I'm curious why my "textbox" binding overrode the platform
> "textbox[type=search]" binding, when the latter has higher specificity...

Answer: Because toolkit/content/xul.css is a UA stylesheet, while mobile/chrome/content/browser.css is an author stylesheet.
Comment on attachment 490375 [details] [diff] [review]
alternate patch

Yeah, XBL can be a pain. Maybe we could move these into a new bindings/textbox.xml file.

We should be on the lookout for a different way to handle the context menu in the future.
Attachment #490375 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/3748d55343cd
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101115 Namoroka/4.0b8pre Fennec/4.0b3pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101115 Namoroka/4.0b8pre Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
Comment on attachment 490234 [details] [diff] [review]
Fix

Cleaning up requests
Attachment #490234 - Flags: review?(mark.finkle)
You need to log in before you can comment on or make changes to this bug.