If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

m18: <noscript> parsing is not compatible with Navigator

RESOLVED DUPLICATE of bug 56501

Status

()

Core
HTML: Parser
P3
normal
RESOLVED DUPLICATE of bug 56501
17 years ago
16 years ago

People

(Reporter: root, Assigned: harishd)

Tracking

Trunk
All
NetBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Many pages on eBay contain code of the form:

<noscript>
<table ...>
....
</noscript>
...
</table>

For example, as of right now, the entire front page of eBay, except for the
eBay logo and the 4-item quick navigation bar at the top, is inside such a
table.  With JavaScript enabled, the <table> tag is not parsed, and Mozilla
throws out the rest of the table (and thus the rest of the page).  Navigator
4.75 does not appear to do this; it displays the page as I expect.

I note that using the TestOutput program from htmlparser/tests, that the HTML
parser internally moves the </noscript> after the end of the table.

I've tested this on NetBSD/macppc, NetBSD/i386 and NetBSD/sparc, so it's at
least not CPU-specific.  Note: YOU MUST HAVE JAVASCRIPT ENABLED FOR THE
PROBLEM TO OCCUR.

If someone will tell me HOW, I will submit a screenshot and an example of the
actual HTML causing the problem.
(Reporter)

Updated

17 years ago
Hardware: Macintosh → All
(Reporter)

Comment 1

17 years ago
Created attachment 19712 [details]
Front page from eBay, demonstrating the problem
(Reporter)

Comment 2

17 years ago
Created attachment 19713 [details]
Screenshot of broken display
(Reporter)

Comment 3

17 years ago
Also happens on Linux/x86.

Comment 4

17 years ago
Worksforme, build 2000-11-24-04-trunk on Windows 98 SE. Reporter, could you try
with a newer build, lots of stuff have been fixed since M18.
(Reporter)

Comment 5

17 years ago
The patch for PR 56501 fixes this.


*** This bug has been marked as a duplicate of 56501 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
updated qa contact.
QA Contact: janc → bsharma

Updated

16 years ago
QA Contact: bsharma → moied
You need to log in before you can comment on or make changes to this bug.