Arial Black font is not rendered correctly with DirectWrite

RESOLVED DUPLICATE of bug 584769

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 584769
8 years ago
3 years ago

People

(Reporter: Emil Ivanov, Unassigned)

Tracking

({regression, testcase})

Trunk
x86_64
Windows 7
regression, testcase
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 490233 [details]
testcase

Under Firefox 4.0b8pre the Arial Black font looks like completely different font.
It should looks like "bolder" than Arial Bold.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Updated

8 years ago
Keywords: regressionwindow-wanted
(Reporter)

Comment 1

8 years ago
When Hardware Acceleration is off, the font is rendered as expected.
Summary: Arial Black font is not rendered correctly → Arial Black font is not rendered correctly with DirectWrite
(Reporter)

Updated

8 years ago
Component: Layout: Text → Graphics
QA Contact: layout.fonts-and-text → thebes
This seems like a duplicate of 584769
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584769
(Reporter)

Comment 4

8 years ago
(In reply to comment #2)
> This seems like a duplicate of 584769

Yes but its marked as invalid and i couldnt find existing bugs when i searched.
I cant believe they want to leave it that way.

Old pages will looks broken with this new behavior introduced with Firefox 4...

If Arial Black is same as Arial 900, then make the "black" keyword equal to 900 and the problem will be solved.

Also when Arial Black is used with font-weight property, the second has no effect.
blocking2.0: ? → -
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.