css menu draws incorrectly

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
minor
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Bradley Baetz, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
At the above url, move the mouse over the left hand side menu. When entering an
option's region, the background correctly becomes blue, but when leaving it,
bits of the blue (usually on the left hand side) don't return to the original
white color. This should not happen.
(Reporter)

Comment 1

18 years ago
Once more with the correct url...

Comment 2

18 years ago
Created attachment 19722 [details]
Testcase

Comment 3

18 years ago
Bug also occurs in build 2000-11-24-04-trunk on Windows 98 SE.
Keywords: testcase
OS: Linux → All
Peter, please triage ASAP. Find the correct owner for this bug and reassign this.
Assignee: clayton → peter.vanderbeken
(Reporter)

Comment 5

17 years ago
At some point in the past, this bug was fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Marking verified in the March 5th build.

Status: RESOLVED → VERIFIED

Comment 7

17 years ago
REOPEN, both the URL and testcase have minor problems. In the testcase, when the
mouse is over the 2nd cell of any table it turns blue correctly but there is a
1-pixel gap of white still at the left edge and at the top edge of the cell.
At the URL, moving the mouse over the links to the left always leaves the
top-left and bottom-left corners white when the item turns blue. Also, sometimes
you get two (or more) areas having blue background at the same time.
Severity: normal → minor
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Reassigning, I haven't received the notification that this was reopened :/.
Assignee: peter.vanderbeken → karnaze
Status: REOPENED → NEW

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Whiteboard: [awd:tbl]

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.1

Comment 9

15 years ago
mass reassign to default owner
Assignee: karnaze → table
Status: ASSIGNED → NEW
Component: Layout → Layout: Tables
QA Contact: petersen → madhur
Target Milestone: mozilla1.1alpha → ---

Updated

15 years ago
Target Milestone: --- → Future

Comment 10

14 years ago
Mats this is wfm winxp 2004090105. Isnt it? 

Comment 11

14 years ago
I still see the bug with build 2004102505 at the given URL, but a bit different: 
sometimes the complete background, not just parts of it, stays blue after moving 
the mouse out. It's not hard to reproduce, you have to move the mouse very 
quickly. When it happens, the highlighted option still has className == 
"LeftNavUp" so Mozilla probably didn't fire the mouseout event which would have 
set className to "LeftNavOff". This seems to be a DOM bug now.

Comment 12

12 years ago
If I understand this bug right, the background-color issue works for me with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061231 Minefield/3.0a2pre

But what is the jumping cell width new in 1.9?

Comment 13

10 years ago
Mats what is going on with this? Could you please create reftest that shows the problem?
WFM, all versions back to Fx 1.0.1 on both Linux and XP.
The Win98 system I originally saw the problem on doesn't exist anymore.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 17 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.