crash [@ xpc::XrayWrapper<JSCrossCompartmentWrapper, xpc::CrossCompartmentXray>::resolveOwnProperty(JSContext*, JSObject*, int, bool, js::PropertyDescriptor*) ]

RESOLVED WORKSFORME

Status

()

Core
XPConnect
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
It is a new crash signature that was introduced by 4.0b8pre/20101111 build.
It is #41 top crasher in today's build.

Signature	xpc::XrayWrapper<JSCrossCompartmentWrapper, xpc::CrossCompartmentXray>::resolveOwnProperty(JSContext*, JSObject*, int, bool, js::PropertyDescriptor*)
UUID	fa4559dd-656f-4033-80bb-120b62101112
Time 	2010-11-12 20:37:54.811914
Uptime	16974
Last Crash	1168596 seconds (1.9 weeks) before submission
Install Age	16974 seconds (4.7 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101112042456
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x1c
User Comments	D'awww. (Oh Hi Laura!)
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9441

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	xpc::XrayWrapper<JSCrossCompartmentWrapper,xpc::CrossCompartmentXray>::resolveOwnProperty 	js/src/xpconnect/wrappers/XrayWrapper.cpp:443
1 	xul.dll 	xul.dll@0xceb1a7 	
2 	xul.dll 	xpc::XrayWrapper<JSCrossCompartmentWrapper,xpc::CrossCompartmentXray>::getPropertyDescriptor 	js/src/xpconnect/wrappers/XrayWrapper.cpp:510
3 	mozjs.dll 	js::JSProxyHandler::get 	js/src/jsproxy.cpp:118
4 	xul.dll 	xpc::XrayWrapper<JSCrossCompartmentWrapper,xpc::CrossCompartmentXray>::get 	js/src/xpconnect/wrappers/XrayWrapper.cpp:745
5 	mozjs.dll 	js::JSProxy::get 	js/src/jsproxy.cpp:763
6 	mozjs.dll 	js::proxy_GetProperty 	js/src/jsproxy.cpp:856
7 	mozjs.dll 	JSObject::getProperty 	js/src/jsobj.h:1079
8 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4167
9 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:665
10 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:768
11 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2341
12 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4744
13 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:665
14 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:768
15 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2341
16 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4744
17 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:665
18 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:768
19 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2341
20 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4744
21 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:665
22 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:768
23 	mozjs.dll 	js::InvokeSessionGuard::invoke 	js/src/jsinterpinlines.h:562
24 	mozjs.dll 	array_extra 	js/src/jsarray.cpp:2723
25 	mozjs.dll 	array_forEach 	js/src/jsarray.cpp:2780
26 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4744
27 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:665
28 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:768
29 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:881
30 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4908
31 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2171
32 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:228
33 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1112
34 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1208
35 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:628

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1d1ff6b489&tochange=0f17e5f1eb01

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=xpc%3A%3AXrayWrapper%3CJSCrossCompartmentWrapper%2C%20xpc%3A%3ACrossCompartmentXray%3E%3A%3AresolveOwnProperty%28JSContext*%2C%20JSObject*%2C%20int%2C%20bool%2C%20js%3A%3APropertyDescriptor*%29
Duplicate of this bug: 611956
Changing to all since a variant of this is seen on Mac and Linux. See the duped bug in Comment 1 for the signature.
OS: Windows 7 → All
Hardware: x86 → All
(Assignee)

Updated

7 years ago
Crash Signature: [@ xpc::XrayWrapper<JSCrossCompartmentWrapper, xpc::CrossCompartmentXray>::resolveOwnProperty(JSContext*, JSObject*, int, bool, js::PropertyDescriptor*) ]

Comment 3

6 years ago
Nothing in the past 4 weeks beyond 4.0. Resolving as works for me.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.