Closed Bug 611989 Opened 9 years ago Closed 9 years ago

Unable to change group name in panorama because the search tab tool greps the focus

Categories

(Firefox Graveyard :: Panorama, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 608714

People

(Reporter: proc.null, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b7) Gecko/20101111 Firefox/4.0b7 Iceweasel/4.0b7
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b7) Gecko/20101111 Firefox/4.0b7 Iceweasel/4.0b7

When trying to change a given name of a tab group in panorama I'm not able to partially change it because no | cursor is displayed, I think that is because the focus is grepped by the search tool that permits to search tabs in groups.

Reproducible: Always

Steps to Reproduce:
1. Create a tab group and give it any name
2. Click on that name and all the string will be selected
3. Try to move with the cursor left-right to navigate the string and modify it
4. Also try to write something and the search tool is displayed and the group name not touched
Actual Results:  
You are not able to navigate the string and you are obligated to change the entire string

Expected Results:  
You could partially change  the string.
I'm not able to move the cursor within the group name to edit it. This is happening for me on the latest 4.0b8pre nightly. Although I don't know if it has anything to do with the search field.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME
The patch for bug 608714 is waiting for approval to land. That will fix this issue. Duping.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608714
Whiteboard: DUPEME
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.