Multiple popups of "Password required" boxes when the master password is activated

RESOLVED DUPLICATE of bug 349641

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 349641
7 years ago
7 years ago

People

(Reporter: Michal Bruncko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Opera/9.80 (Windows NT 5.1; U; en) Presto/2.7.39 Version/11.00
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.11) Gecko/20101013 Thunderbird/3.1.5

After setting of master password for TB there are always three windows popuped with requesting of master password ("Password required" boxes) after TB startup. 
I've defined of six mail (IMAP/SMTP) accounts plus + CalDAV remote calendars with summ of 16 passwords.
After filling first "password required" window starts thunderbird checking mails for all of mail (imap) accounts. But second and third password request (that I've discovered) is from installed Lightning plugin. After filling second pass request calendar will in readonly mode and after filling third pass request calendar will in RW full operating mode.
In error console is nothing interesting about this trouble.
Is possible for Lightning (or other plugins) in some way to reduce master password request reduced to only one request? Master password is perfect feature but with multiple requests is very annoying.

Reproducible: Always

Steps to Reproduce:
1.create multiple accounts (I do no the right number) + lightning remote callendar
2.set master password
3.restart thunderbird
Actual Results:  
three window password required boxes opened after starting of thunderbird

Expected Results:  
only single window password required box opened after starting of thunderbird

Lighning plugin is in version 1.0b2 (modifed by inverse for SOGo groupware)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349641
You need to log in before you can comment on or make changes to this bug.