Firefox 4.0b7 crash mainly close to startup [@ libSystem.B.dylib@0x42b0 ]

RESOLVED DUPLICATE of bug 610715

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 610715
8 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is a crash signature in 4.0b7 on Mac OS X.
It happens at startup or a few minutes after startup.
It is #11 top crasher on Mac OS X in 4.0b7 for the last week.
May be it is related to bug 610715.

Signature	libSystem.B.dylib@0x42b0
UUID	7b3813f1-6571-4c36-9458-929142101113
Time 	2010-11-13 10:29:47.511210
Uptime	23
Last Crash	103113 seconds (1.2 days) before submission
Install Age	103181 seconds (1.2 days) since version was first installed.
Product	Firefox
Version	4.0b7
Build ID	20101104131842
Branch	2.0
OS	Mac OS X
OS Version	10.6.5 10H574
CPU	x86
CPU Info	family 6 model 14 stepping 8
Crash Reason	EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE
Crash Address	0x0
User Comments	
App Notes 	Renderers: 0x21900,0x20400
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libSystem.B.dylib 	libSystem.B.dylib@0x42b0 	
1 		@0x10 	
2 		@0x782f6f64 	
3 	libnspr4.dylib 	PR_Unlock 	nsprpub/pr/src/pthreads/ptsynch.c:237
4 	XUL 	nsXPConnect::GetXPConnect 	js/src/xpconnect/src/nsXPConnect.cpp:157
5 		@0x1 	
6 	XUL 	__static_initialization_and_destruction_0 	js/src/jswrapper.cpp:376
7 		@0x152bb217 	
8 	XUL 	nsPluginHost::ScanPluginsDirectory 	modules/plugin/base/src/nsPluginHost.cpp:1943
9 	XUL 	nsAppDirectoryEnumerator::GetNext 	
10 	XUL 	nsPluginHost::ScanPluginsDirectoryList 	modules/plugin/base/src/nsPluginHost.cpp:2186
11 	XUL 	nsPluginHost::FindPlugins 	modules/plugin/base/src/nsPluginHost.cpp:2274
12 	XUL 	nsPluginHost::LoadPlugins 	modules/plugin/base/src/nsPluginHost.cpp:2209
13 	XUL 	nsPluginHost::GetPluginCount 	modules/plugin/base/src/nsPluginHost.cpp:1571
14 	XUL 	nsPluginArray::GetLength 	dom/base/nsPluginArray.cpp:89
15 	XUL 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179
16 	XUL 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3054
17 	XUL 	XPC_WN_GetterSetter 	js/src/xpconnect/src/xpcprivate.h:2651
18 	XUL 	js::Invoke 	js/src/jscntxtinlines.h:684
19 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:881
...

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=libSystem.B.dylib%400x42b0&version=Firefox%3A4.0b7
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610715
(Assignee)

Updated

7 years ago
Crash Signature: [@ libSystem.B.dylib@0x42b0 ]
You need to log in before you can comment on or make changes to this bug.