[D2D] NVIDIA driver crash [@ nvwgf2um.dll@0x163e40 ]

RESOLVED DUPLICATE of bug 612125

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 612125
8 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is a new crash signature that exists in 4.0b7, b8pre.
It is #176 top crasher in 4.0b7 for the last week.

Signature	nvwgf2um.dll@0x163e40
UUID	3af2d125-952a-4fc8-bbc5-edc742101114
Time 	2010-11-14 03:44:04.957479
Uptime	52178
Last Crash	52180 seconds (14.5 hours) before submission
Install Age	171890 seconds (2.0 days) since version was first installed.
Product	Firefox
Version	4.0b7
Build ID	20101104142426
Branch	2.0
OS	Windows NT
OS Version	6.1.7601 Service Pack 1, v.178
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x3c
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0a28

Frame 	Module 	Signature [Expand] 	Source
0 	nvwgf2um.dll 	nvwgf2um.dll@0x163e40 	
1 	nvwgf2um.dll 	nvwgf2um.dll@0x163d1d 	
2 	nvwgf2um.dll 	nvwgf2um.dll@0x16db4b 	
3 	nvwgf2um.dll 	nvwgf2um.dll@0x3c11d 	
4 	d3d10_1core.dll 	d3d10_1core.dll@0x2ebe0 	
5 	d3d10_1core.dll 	d3d10_1core.dll@0x31266 	
6 	xul.dll 	_cairo_d2d_acquire_source_image 	gfx/cairo/cairo/src/cairo-d2d-surface.cpp:2455
7 	d3d10_1core.dll 	d3d10_1core.dll@0x157f 	
8 	xul.dll 	_cairo_surface_acquire_source_image 	gfx/cairo/cairo/src/cairo-surface.c:1304
9 	xul.dll 	_cairo_surface_clone_similar 	gfx/cairo/cairo/src/cairo-surface.c:1630
10 	xul.dll 	_cairo_pattern_acquire_surface_for_surface 	gfx/cairo/cairo/src/cairo-pattern.c:2161
11 	xul.dll 	_cairo_pattern_acquire_surface 	gfx/cairo/cairo/src/cairo-pattern.c:2339
12 	xul.dll 	_cairo_pattern_acquire_surfaces 	gfx/cairo/cairo/src/cairo-pattern.c:2415
13 	xul.dll 	_cairo_image_surface_composite 	gfx/cairo/cairo/src/cairo-image-surface.c:1136
14 	mozcrt19.dll 	arena_dalloc_small 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4204
15 	mozcrt19.dll 	arena_dalloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4284
16 	xul.dll 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:469

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=nvwgf2um.dll%400x163e40

Updated

8 years ago
Blocks: 605749
(Reporter)

Comment 1

8 years ago
It is now #165 top crasher in 4.0b7 for the last 2 weeks and #1 top driver crasher.

Chris,
As Dbaron's script does not work for correlation by version, is it possible to have a correlation by version of nvwgf2um.dll?
(Reporter)

Comment 2

8 years ago
It is the same one as bug 612525 except NVIDIA's driver version which is 8.17.12.5896 or 8.17.12.5919.
(In reply to comment #2)
> It is the same one as bug 612525 except NVIDIA's driver version which is
> 8.17.12.5896 or 8.17.12.5919.

I'm not sure if that's a big enough reason to keep a separate report open?
OK, i'm going to dupe this because elsewhere we've never kept separate bugs for separate driver versions.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 612125
(Assignee)

Updated

7 years ago
Crash Signature: [@ nvwgf2um.dll@0x163e40 ]
You need to log in before you can comment on or make changes to this bug.