Test Pilot Popup Crashes Firefox



Mozilla Labs Graveyard
Test Pilot
7 years ago
2 years ago


(Reporter: Jamie Kitson, Unassigned)




(Whiteboard: performance)


(1 attachment)



7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

Several minutes after starting firefox the Test Pilot (user study?) popup automatically pops up and firefox stops responding (the window goes grey, alt-tab still changes the title of the window correctly).

Reproducible: Always

Steps to Reproduce:
1. Start firefox
2. Wait for test piolt popup
Actual Results:  
Firefox crashes

Expected Results:  
Firefox doesn't crash

Comment 1

7 years ago
Please provide a crash id or stacktrace -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Version: unspecified → Trunk

Comment 2

7 years ago
Do you know if there's a way I can get the notification popup up without waiting for it?

Comment 3

7 years ago
I don't but someone may....
Component: General → Test Pilot
Product: Firefox → Mozilla Labs
QA Contact: general → test-pilot
Target Milestone: --- → --

Comment 4

7 years ago
Hi Jamie, thanks for reporting the bug. Sorry I didn't get back to you sooner.

Yes, you can get the notification popup using the following steps:

1. Go to the URL chrome://testpilot/content/debug.html
2. Choose a study (such as 'week in the life v2') from the drop-down menu in the upper left.
3. Click the "Reset Task" button
4. Click the "Reload All Experiments" button
5. Click "Notify Me".

If you could do that and then attach the resulting crash stacktrace to this bug, we would really appreciate it.  Thanks.

Comment 5

7 years ago
The url in step one gives a blank page for me. I disabled test pilot a while ago and am not sure how to re-enable it if that's the problem.


7 years ago
Whiteboard: performance


7 years ago
Priority: -- → P1
Target Milestone: --- → 1.2

Comment 6

7 years ago
Created attachment 521318 [details]
console output for Fx-4.0 clean profile with Test Pilot installed

I'm not 100% sure if it is the same bug but i've just upgraded from Fx-3.6 to 4.0 release, and Fx stops to work as described above. 
I've started new Fx profile, installed Test Pilot 1.1. on It and it also died.
I've tried to reproduce this using the directions in comment 4. But I get an error that says:

    TypeError on line 179 of file resource://testpilot/modules/lib/securable-module.js -> resource://testpilot/modules/jar-code-store.js
    path.indexOf is not a function

This happens a little after I click "Reload All Experiments".


7 years ago
Target Milestone: 1.2 → 1.3

Comment 8

7 years ago
In the comments thread from bug #643746, Jakub wrote:

I'm not sure if it can help but as I understand you have some problems with
reproducing this bug. So probably I have different problem also connected to
test Pilot because:

- My Fx-4.0 hangs every time when Test Pilot is installed and enabled also on
fresh profile where TestPilot-1.1 
- My Fx just hangs with some magic ;-) output to console but without crash
report sent to Mozilla 

BTW isn't good idea to upgrade test pilot to 1.2 with only difference that it
should be set as NOT compatible with Fx-4.x?

and then I wrote:

Jakub: Could you tell me what the "magic" output to the console is?  Rather
than marking Test Pilot 1.2 incompatible with Fx 4, I would rather *make it
compatible* with Fx 4!!

And then Jakub wrote:

Created attachment 523534 [details]
Console output, clean profile, test pilot + gentoo x86

I'm attaching console output from work (here where I am now). It's also gentoo
linux on x86 machine. Fx is hanging after few seconds every time if Test Pilot
is installed and enabled.

As i said before same output from my private (amd64) machine is attached to bug

About compatibility of Test pilot. Of course it is better to make it working
with Fx4 but in case it is not trivial maybe it is good idea to turn it off for
some time (time to find and kill the bug). Many ppl may think that they lost
their profiles after upgrade to Fx-4.0.

Comment 9

7 years ago
Jakub:  I am trying to read your console output.  I'm unfamiliar with the "memory map" that is output to the console when the crash happens -- is this a special debug build, or does Firefox on Linux always dump a memory map to console when it crashes?

Anyway, it looks like the proximate cause of the crash is an attempt to free() something invalid, but I don't know the ultimate cause.  Somebody who knows more than me about reading crash dumps should take a look at it.

This is the only part that looks obviously Test Pilot related: 

7f0b42e4c000-7f0b42e4e000 r--p 00000000 08:04 42074347                   /home/wariat/.mozilla/firefox/fg42ck0n.test/TestPilotExperimentFiles/base_classes.jar
7f0b42e6e000-7f0b42e71000 r--p 00000000 08:04 42074349                   /home/wariat/.mozilla/firefox/fg42ck0n.test/TestPilotExperimentFiles/week_life.jar
7f0b42e91000-7f0b42e92000 r--p 00000000 08:04 42074348                   /home/wariat/.mozilla/firefox/fg42ck0n.test/TestPilotExperimentFiles/basic-survey.jar

which is kind of interesting.  The .jar files are supposed to be writable (because we need to overwrite them when there are newer versions) but here I see "r--p" which I *assume* is a permissions string showing the files are read-only.  I wonder if this is related to the crash?  It's trying to overwrite the files, failing, and then... well that ought to just raise an exception, not crash the browser, but maybe the failed overwrite case is triggering something else bad to happen...?
Ever confirmed: true
The output that glibc generates in these cases usually isn't very useful. It would be much more helpful to get a minidump. If you guys go to the URL "about:crashes", you will hopefully see a list of links to crash data, sorted by date. If you can find a few that seem to correspond to when you crashed with this bug, and post those URLs here, that would be most helpful!

Comment 11

7 years ago
I'm also unfamiliar with all that stuff, i can try to help and send anything you want but excuse me i'm not understand much of this output. 
I can compile Fx / xulrunner with debug enabled and try to copy gdb bt if it can help. But if possible I don't want to recompile whole system with debug. 

About:crashes is empty here and @ work (similar configuration but x86 machine). It is also possible that it is just gentoo related bug it is the question e.g. to the original reporter of this bug. 

What i'm sure:
- i've been using test pilot with Fx-3.6 for many months on several computers 
- it started to crash Fx/something after Fx upgrade to 4.0 also on new profile when test pilot is enabled
- if testpilot is disabled i don't have any problems with Fx 4

Comment 12

7 years ago
I am running Arch. I have not been able to get test pilot to popup since I disabled it and so hence cannot recreate the bug. I am sure that it was test pilot that caused the crash. The only unusual thing about my setup really is that I run dwm, a tiling WM.

Comment 13

7 years ago
I've just upgraded testpilot add on to 1.1.1 version, and it is still crashing Fx as before.

Comment 14

7 years ago
I just reinstalled Test Pilot and tried to follow the steps in Comment #4, but when I reach step 4. and click Reload All Experiments I get six of the following error messages and Notify Me does nothing.

TypeError on line 179 of file resource://testpilot/modules/lib/securable-module.js -> resource://testpilot/modules/jar-code-store.js: path.indexOf is not a function

Comment 15

7 years ago
I'm having a similar issue, although it might not be the exact same one.

When the test pilot notification pops up, the rendering is crazy slow. So slow in fact, that what in effect happens is that a gray rectangle blocks out that corner of the screen and the Firefox window refreshes maybe once every five seconds, rendering the whole thing unusable. Someone with less technical literacy than me could very easily mistake that for a "crash." There is nothing on stdout or stderr when this happens. It also happens with or without hardware acceleration enabled.

Test Pilot is version 1.1.3. The platform is 32-bit Linux Mint, which is pretty much the same as Ubuntu with a few different defaults. I've been using the Firefox Nightly builds from the Ubuntu PPA, including Test Pilot, for months now. This is a NEW ISSUE that started happening yesterday when I upgraded from Mint 9 (Ubuntu 10.04) to Mint 10 (Ubuntu 10.10.) This included a driver update, but since this happens without hardware acceleration, that *shouldn't* have caused it.

I'm aware that this is probably not enough information, but I'm not well versed enough in Firefox troubleshooting to know which information would be useful-- any suggestions for what I should submit?

Here is the output of the lshw utility, which lists my hardware configuration:

For now I've disabled Test Pilot altogether.


2 years ago
Product: Mozilla Labs → Mozilla Labs Graveyard
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.