WebGL crash [@mozilla::gl::GLContext::fGenerateMipmap]

RESOLVED DUPLICATE of bug 738126

Status

()

--
critical
RESOLVED DUPLICATE of bug 738126
8 years ago
7 years ago

People

(Reporter: posidron, Unassigned)

Tracking

(Blocks: 1 bug, {crash, testcase})

Trunk
x86
Linux
crash, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(status1.9.2 unaffected, status1.9.1 unaffected)

Details

(Whiteboard: [sg:vector-dos (video driver)], crash signature)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 490499 [details]
testcase
(Reporter)

Comment 1

8 years ago
Created attachment 490500 [details]
callstack
(Reporter)

Updated

8 years ago
OS: Mac OS X → Linux
Can't reproduce here (linux x86-64 NVIDIA). The callstack suggests a driver crash, but there's a chance that de-asynchronous-izing OpenGL with glFinish() calls would make it look different, as in bug 593867.

The good news though is that the GL debug mode, which does that, is now readily available in debug builds. So can you please:

  - either grab a debug build of Minefield (for example the mozilla-central builds at http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/ ) and run with the environment variable MOZ_GL_DEBUG defined.

  - or add a WebGL finish() call after every WebGL call in your test case.

Then reproduce the crash: the callstack you'll get will be more interesting to look at.
(Reporter)

Comment 3

8 years ago
Hello Benoit,

Driver: i965_dri.so - http://www.intel.com/p/en_US/support/highlights/chpsts/965

I am using a debug build of mozilla-central. 
Defining MOZ_GL_DEBUG or adding finish() showed no difference on my side.
OK, thanks, so we know for sure that the glGenerateMipmap() function is crashy in the linux Intel driver.

Can you tell me the version of relevant packages on your system? (driver, X, kernel...) That will be useful to know if we eventually go the route of blacklisting certain drivers on linux.
(Reporter)

Comment 5

8 years ago
Ubuntu 10.10 - 2.6.35-22-generic-pae
X.Org X Server 1.9.0

There was no module named i965 only i915 (video):

$ modinfo i915
filename:       /lib/modules/2.6.35-22-generic-pae/kernel/drivers/gpu/drm/i915/i915.ko
license:        GPL and additional rights
description:    Intel Graphics
author:         Tungsten Graphics, Inc.
license:        GPL and additional rights
srcversion:     F936DAC9185D063B604C4FE
alias:          pci:v00008086d0000010Asv*sd*bc03sc00i*
depends:        drm,drm_kms_helper,video,intel-agp,i2c-algo-bit
vermagic:       2.6.35-22-generic-pae SMP mod_unload modversions 686 
parm:           modeset:int
parm:           fbpercrtc:int
parm:           powersave:int
parm:           lvds_downclock:int
The callstack looks like a memory read access violation due to a null dereference in the driver.
status1.9.1: --- → unaffected
status1.9.2: --- → unaffected
Keywords: crash, testcase
Whiteboard: [sg:vector-dos (video driver)]
Blocks: 624593
We're not going to whitelist the versions of Mesa and of the Intel driver used in Ubuntu 10.10 anyway.

Can this be reproduced in Ubuntu 11.04?
(Reporter)

Updated

7 years ago
Blocks: 658170
(Assignee)

Updated

7 years ago
Crash Signature: [@mozilla::gl::GLContext::fGenerateMipmap]
Duplicate of this bug: 667310

Comment 10

7 years ago
I just hit this in bp-c8b50851-c396-47dc-b39d-d9ef52111118 - has the fixed DRI code not shipped yet? I'm on openSUSE Factory, currently it should be more or less at the state of just-released openSUSE 12.1 and given that https://bugs.freedesktop.org/show_bug.cgi?id=32096 was resolved in June I wonder if I still have an old library or if this is something new.
The changeset in https://bugs.freedesktop.org/show_bug.cgi?id=32096#c6 should be included in Mesa 7.11 (the version reported with that crash).

http://cgit.freedesktop.org/mesa/mesa/log/src/mesa/main/mipmap.c?h=7.11
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738126
You need to log in before you can comment on or make changes to this bug.