If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Open app tab history page in new tab causes new tab to open as application tab

RESOLVED DUPLICATE of bug 623779

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 623779
7 years ago
7 years ago

People

(Reporter: havvy, Assigned: zpao)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(blocking2.0 .x+)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

Opening a new tab from an application tab should always open as a new normal tab.  Current behavior has a case where this fails.

Reproducible: Always

Steps to Reproduce:
1.  Find an application tab that has a history (back button enabled).
2.  Open history page in a new tab (via say, a middle click)
3.  Watch as new tab opens as an application tab.
Confirmed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre ID:20101111030745
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Flags: in-testsuite?
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
This is pretty narrow, not sure I'd block on this, but the fact that a new tab opened in any way whatsoever can be an app tab seems like a pretty serious issue that could result in app tabs in other circumstances as well. Blocking+ for investigation.
blocking2.0: ? → final+
This goes through duplicateTab which in session restore will keep attributes like pinned/hidden/etc.

We could filter some attributes out pretty easily.
Assignee: nobody → paul
Notes from the Grand Retriage: branch candidate, not holding FF4 for it.
blocking2.0: final+ → .x
(Reporter)

Comment 5

7 years ago
A duplicate bug has a patch that fixes this.  Marking this as a duplicate of that bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623779
You need to log in before you can comment on or make changes to this bug.