Password Manager does not offer to remember HTTP Authentication login info

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: WFM?)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Steps to reproduce:
1. Load a page that uses HTTP Authentication (e.g. intranet.mozilla.org) in a profile that is not already authenticated and does not have a stored password for the site.
2. Log in to the site successfully.

Expected results: "Remember password?" doorhanger notification appears.
Actual results: No password manager notification appears.

I tested this in a new, empty profile in today's Linux mozilla-central nightly; I also noticed it in nightly builds from the last few days but I'm not sure when it first regressed:
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101114 Firefox/4.0b8pre
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
(Reporter)

Comment 1

7 years ago
The last good nightly build on Linux i686 was 2010-09-16-03-mozilla-central.  The first bad build is 2010-09-17-03-mozilla-central.  The regression range is:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f38ef1080bfe&tochange=268ef4ccb5ff

Could this be related to bug 61098?
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

7 years ago
Created attachment 490693 [details]
log output with signon.debug
blocking2.0: ? → beta9+

Comment 3

7 years ago
WFM on today's Mac nightly.
This is WFM on Linux, just built from http://hg.mozilla.org/mozilla-central/rev/959e7a50a125. Could be it was broken and has since been fixed.

Can you confirm it's still broken for you?

Can you also confirm that you don't have intranet.mozilla.org in your exceptions list? The log looks identical to that case (though the log also looks the same as if it would have prompted to save - since that's a doorhanger it doesn't show up in the password manager logging AFAIK).

Comment 5

7 years ago
WFM too.

Updated

7 years ago
Whiteboard: WFM?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 6

7 years ago
As per today's meeting, beta 9 will be a time-based release. Marking these all betaN+. Please move it back to beta9+ if you believe it MUST be in the next beta (ie: trunk is in an unshippable state without this)
blocking2.0: beta9+ → betaN+
Keywords: regression

Updated

7 years ago
Keywords: regression
You need to log in before you can comment on or make changes to this bug.