Syntax errors in bugzilla.dtd prevent parsing of XML-formatted bug descriptions

VERIFIED DUPLICATE of bug 538428

Status

()

Bugzilla
Query/Bug List
VERIFIED DUPLICATE of bug 538428
7 years ago
7 years ago

People

(Reporter: Jens Alfke, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.12 (KHTML, like Gecko) Chrome/9.0.572.1 Safari/534.12
Build Identifier: 3.6.2

There are two errors in bugzilla.dtd. These cause XML parse errors when trying to read XML-formatted bug descriptions. Specifically, this is breaking FogBugz's Bugzilla import script.

(1) On line 85. there is a missing #REQUIRED or #IMPLIED keyword:
          type_id CDATA
(2) There are two declarations of the delta_ts element:
<!ELEMENT delta_ts (#PCDATA)>

Adding an #IMPLIED keyword and removing the second delta_ts declaration makes xmllint happy.

Reproducible: Always

Steps to Reproduce:
1. Fetch some bug in XML form, e.g. from <https://bugzilla.mozilla.org/show_bug.cgi?ctype=xml&id=1>
2. Run the xmllint tool on the downloaded XML
Actual Results:  
DTD-related errors are reported.

Expected Results:  
Should have parsed correctly.
(Reporter)

Updated

7 years ago
Summary: Syntax errors in bugzilla.dtd prevent parsing of bugs → Syntax errors in bugzilla.dtd prevent parsing of XML-formatted bug descriptions

Comment 1

7 years ago
(In reply to comment #0)
> (2) There are two declarations of the delta_ts element:
> <!ELEMENT delta_ts (#PCDATA)>

Except that the first one is for the bug, and the 2nd one for the attachment.
After upgrading to 3.6.2 yesterday, we hit this problem almost immediately.
This is a BIG problem as it apparently blows IE completely out of the water.

Can someone confirm that #IMPLIED is the correct keyword to add to the
type_id line?

Comment 3

7 years ago
IE9 doesn't complain when I view a bug as XML.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
Target Milestone: --- → Bugzilla 4.0
Version: unspecified → 3.6.2
LpSolit, is this related to the work I have done on bug 538428 and can be closed as duplicate? bug 538428 should address the xmllint issues as I used that for testing my changes.

dkl

Comment 5

7 years ago
Ah yes, definitely.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 4.0 → ---
Duplicate of bug: 538428
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.