Last Comment Bug 612480 - Middle-clicking bookmarks toolbar item does not work when Firefox is in the background
: Middle-clicking bookmarks toolbar item does not work when Firefox is in the b...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 4.0b11
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 562998
Blocks: 581876
  Show dependency treegraph
 
Reported: 2010-11-15 19:13 PST by Jesse Ruderman
Modified: 2011-06-30 05:23 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jesse Ruderman 2010-11-15 19:13:49 PST
Steps:
1. Make Firefox lose focus to another application.
2. Hover over a bookmarks toolbar item
     Result: hover effect (indicating click-through)
3. Middle-click
     Result: nothing happens
     Expected: open a in a new tab, and maybe focus the window

Related to bug 460782?

This is one of the cases mentioned in bug 581876.
Comment 1 Marco Bonardo [::mak] 2010-11-16 02:37:11 PST
there is also bug 562998 that could be related
Comment 2 Markus Stange [:mstange] 2011-01-19 00:12:14 PST
The patch in bug 562998 fixes this for me, but it doesn't fix bug 460782.
Comment 3 Markus Stange [:mstange] 2011-06-30 05:23:13 PDT
Looks like bug 562998 fixed this.

Note You need to log in before you can comment on or make changes to this bug.