crash [@ libxul.so@0xbf0014 ]

RESOLVED DUPLICATE of bug 623161

Status

()

--
critical
RESOLVED DUPLICATE of bug 623161
8 years ago
7 years ago

People

(Reporter: scoobidiver, Assigned: jrmuizel)

Tracking

({crash, topcrash})

Trunk
ARM
Android
crash, topcrash
Points:
---

Firefox Tracking Flags

(fennec2.0+)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is #21 top crasher in Fennec 4.0b3pre for the last week.

Signature	libxul.so@0xbf0014
UUID	68133d1e-1421-4d98-90da-797422101115
Time 	2010-11-15 18:05:30.700995
Uptime	390
Last Crash	753883 seconds (1.2 weeks) before submission
Install Age	65522 seconds (18.2 hours) since version was first installed.
Product	Fennec
Version	4.0b3pre
Build ID	20101114041859
Branch	2.0
OS	Linux
OS Version	0.0.0 Linux 2.6.35.7-defrost-bravo #232 PREEMPT Sun Nov 7 11:41:43 CET 2010 armv7l
CPU	arm
CPU Info	
Crash Reason	SIGSEGV
Crash Address	0x110
User Comments	
App Notes 	HTC HTC Desire
htc_wwe/htc_bravo/bravo/bravo:2.2/FRF91/226611:user/release-keys
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	libxul.so@0xbf0014 	
1 	libxul.so 	neon_composite_src_8888_0565 	gfx/cairo/libpixman/src/pixman-arm-neon.c:45
2 	libxul.so 	neon_composite_src_8888_0565 	gfx/cairo/libpixman/src/pixman-arm-neon.c:45
3 	libxul.so 	pixman_image_composite32 	gfx/cairo/libpixman/src/pixman.c:837
4 	libxul.so 	pixman_image_composite 	gfx/cairo/libpixman/src/pixman.c:881
5 	libxul.so 	_cairo_image_surface_composite 	gfx/cairo/cairo/src/cairo-image-surface.c:1175
6 	libxul.so 	_cairo_surface_composite 	gfx/cairo/cairo/src/cairo-surface.c:1828
7 	libxul.so 	_clip_and_composite_trapezoids 	gfx/cairo/cairo/src/cairo-surface-fallback.c:790
8 	libxul.so 	_cairo_surface_fallback_paint 	gfx/cairo/cairo/src/cairo-surface-fallback.c:1042
9 	libxul.so 	_cairo_surface_paint 	gfx/cairo/cairo/src/cairo-surface.c:2020
10 	libxul.so 	_cairo_gstate_paint 	gfx/cairo/cairo/src/cairo-gstate.c:988
11 	libxul.so 	_moz_cairo_paint 	gfx/cairo/cairo/src/cairo.c:2118
12 	libxul.so 	_moz_cairo_paint_with_alpha 	gfx/cairo/cairo/src/cairo.c:2147
13 	libxul.so 	gfxContext::Paint 	gfx/thebes/gfxContext.cpp:739
14 	libxul.so 	gfxPlatform::OptimizeImage 	gfx/thebes/gfxPlatform.cpp:387
15 	libxul.so 	imgFrame::Optimize 	nsAutoPtr.h:954
16 	libxul.so 	mozilla::imagelib::RasterImage::DecodingComplete 	modules/libpr0n/src/RasterImage.cpp:1048
17 	libxul.so 	mozilla::imagelib::Decoder::PostDecodeDone 	nsCOMPtr.h:800
18 	libxul.so 	mozilla::imagelib::nsPNGDecoder::end_callback 	modules/libpr0n/decoders/nsPNGDecoder.cpp:830
19 	libxul.so 	MOZ_PNG_push_have_end 	modules/libimg/png/pngpread.c:1907
20 	libxul.so 	MOZ_PNG_push_read_chunk 	modules/libimg/png/pngpread.c:364
21 	libxul.so 	MOZ_PNG_proc_some_data 	modules/libimg/png/pngpread.c:65
22 	libxul.so 	MOZ_PNG_process_data 	modules/libimg/png/pngpread.c:39
23 	libxul.so 	mozilla::imagelib::nsPNGDecoder::WriteInternal 	modules/libpr0n/decoders/nsPNGDecoder.cpp:349
24 	libxul.so 	mozilla::imagelib::Decoder::Write 	modules/libpr0n/src/Decoder.cpp:102
25 	libxul.so 	mozilla::imagelib::RasterImage::WriteToDecoder 	modules/libpr0n/src/RasterImage.cpp:2226
26 	libxul.so 	mozilla::imagelib::RasterImage::AddSourceData 	modules/libpr0n/src/RasterImage.cpp:1208
27 	libxul.so 	mozilla::imagelib::RasterImage::WriteToRasterImage 	modules/libpr0n/src/RasterImage.cpp:2701
28 	libxul.so 	nsPipeInputStream::ReadSegments 	xpcom/io/nsPipe3.cpp:801
29 	libxul.so 	imgRequest::OnDataAvailable 	modules/libpr0n/src/imgRequest.cpp:1155
30 	libxul.so 	ProxyListener::OnDataAvailable 	modules/libpr0n/src/imgLoader.cpp:2020
31 	libxul.so 	nsJARChannel::OnDataAvailable 	modules/libjar/nsJARChannel.cpp:937
32 	libxul.so 	nsInputStreamPump::OnStateTransfer 	netwerk/base/src/nsInputStreamPump.cpp:513
33 	libxul.so 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:400
34 	libxul.so 	nsInputStreamReadyEvent::Run 	nsCOMPtr.h:663
35 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:609
36 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
37 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
38 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:220
39 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:512
40 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:187
41 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:192
42 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3684
43 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:131
44 	libc.so 	libc.so@0x11453 	
45 	libc.so 	libc.so@0x10f3f 

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=libxul.so%400xbf0014&version=Fennec%3A4.0b3pre
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
Keywords: topcrash

Comment 1

8 years ago
jeff, could you take a look?
Assignee: nobody → jmuizelaar
tracking-fennec: ? → 2.0+
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623161
Crash Signature: [@ libxul.so@0xbf0014 ]
You need to log in before you can comment on or make changes to this bug.