[OGL] startup crash [@ mozilla::layers::RenderColorLayer ]

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, topcrash})

Trunk
ARM
Android
crash, topcrash
Points:
---

Firefox Tracking Flags

(fennec+)

Details

(crash signature)

(Reporter)

Description

7 years ago
It is #49 top crasher in Fennec 4.0b3pre for the last week.

Signature	mozilla::layers::RenderColorLayer
UUID	3e0ef609-2f6a-49ed-b42a-e7e7b2101114
Time 	2010-11-14 20:17:51.9971
Uptime	6
Install Age	503 seconds (8.4 minutes) since version was first installed.
Product	Fennec
Version	4.0b3pre
Build ID	20101114041859
Branch	2.0
OS	Linux
OS Version	0.0.0 Linux 2.6.32.9-ga42712e #1 PREEMPT Wed Sep 1 20:47:21 CDT 2010 armv7l
CPU	arm
CPU Info	
Crash Reason	SIGSEGV
Crash Address	0x4
User Comments	
App Notes 	motorola DROIDX
verizon/droid2_vzw/cdma_droid2/droid2:2.2/VZW/22.20:user/ota-rel-keys,release-keys
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	mozilla::layers::RenderColorLayer 	GLContext.h:1601
1 	libxul.so 	mozilla::layers::ColorLayerOGL::RenderLayer 	gfx/layers/opengl/ColorLayerOGL.cpp:83
2 	libxul.so 	mozilla::layers::ContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:204
3 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	nsAutoPtr.h:1098
4 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	nsAutoPtr.h:954
5 	libxul.so 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:477
6 	libxul.so 	nsDisplayList::PaintRoot 	layout/base/nsDisplayList.cpp:384
7 	libxul.so 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1452
8 	libxul.so 	PresShell::Paint 	layout/base/nsPresShell.cpp:6092
9 	libxul.so 	nsViewManager::RenderViews 	nsRegion.h:107
10 	libxul.so 	nsViewManager::Refresh 	view/src/nsViewManager.h:250
11 	libxul.so 	nsViewManager::DispatchEvent 	nsCOMPtr.h:492
12 	libxul.so 	HandleEvent 	nsCOMPtr.h:492
13 	libxul.so 	nsWindow::DispatchEvent 	widget/src/android/nsWindow.cpp:578
14 	libxul.so 	nsWindow::DrawTo 	nsRegion.h:107
15 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:842
16 	libxul.so 	nsWindow::OnDraw 	nsAutoPtr.h:1098
17 	libxul.so 	nsWindow::OnAndroidEvent 	widget/src/android/nsWindow.cpp:770
18 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/android/nsAppShell.cpp:286
19 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:163
20 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:309
21 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:578
22 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
23 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
24 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:220
25 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:512
26 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:187
27 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:192
28 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3684
29 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:131
30 	libc.so 	libc.so@0x10f27 	
31 	libc.so 	libc.so@0x10a13 	

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=mozilla%3A%3Alayers%3A%3ARenderColorLayer&version=Fennec%3A4.0b3pre
(Reporter)

Comment 1

7 years ago
It is #2 top crasher in Fennec 4.0b4pre during the last week.
Note: The ranking of startup crashes in nightlies is not representative because it can be caused by several attempts from the same user.
blocking2.0: --- → ?
Keywords: topcrash
Summary: crash [@ mozilla::layers::RenderColorLayer ] → [OGL] startup crash [@ mozilla::layers::RenderColorLayer ]
(Reporter)

Updated

7 years ago
blocking2.0: ? → ---
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b4+

Updated

7 years ago
tracking-fennec: 2.0b4+ → 2.0next+
tracking-fennec: 2.0next+ → 6+
tracking-fennec: 6+ → 7+
(Assignee)

Updated

7 years ago
Crash Signature: [@ mozilla::layers::RenderColorLayer ]
tracking-fennec: 7+ → +

Updated

6 years ago
Blocks: 607684
I see no instance of this crash signature. The OGL code has changed significantly. Please re-open if this crash is seen again.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.