[Regression] No time out when trying to go to a web page and failing a network connection

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({polish, ux-userfeedback})

Trunk
ARM
Maemo
polish, ux-userfeedback

Details

Attachments

(1 attachment)

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101116 Firefox/4.0b8pre Fennec/4.0b3pre

1. without having a network connection, launch fennec and go to www.google.com
2. when prompted, try to connect to a network that requires a password and fail the login

Expected: after failing the network connection, the timeout web page displays
Actual: the webpage keeps cycling
tracking-fennec: --- → ?
Summary: No time out when trying to go to a web page and failing a network connection → [Regression] No time out when trying to go to a web page and failing a network connection
tracking-fennec: ? → 2.0+
Keywords: polish

Comment 2

8 years ago
Looks like this behaves more like it ought to, now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Instead of cycling on an empty page, could we show a page that tells the user about connection issues while we keep trying to load the page? That would make for a better user experience.
Status: RESOLVED → REOPENED
Keywords: ux-feedback
Resolution: WORKSFORME → ---
(In reply to comment #3)
> Instead of cycling on an empty page, could we show a page that tells the user
> about connection issues while we keep trying to load the page? That would make
> for a better user experience.

please file a new bug
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.