If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TEST_PATH has stopped working for 'make crashtest'

RESOLVED FIXED in mozilla2.0b8

Status

()

Core
Build Config
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Ehsan, Assigned: mounir)

Tracking

({regression})

Trunk
mozilla2.0b8
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

From bug 610290 comment 4:

I used to be able to do:

make -C objdir crashtest TEST_PATH=path/to/crashtest.list

Now, neither of these two work, and they both result in the entire crashtest
suite to be run:

make -C objdir crashtest TEST_PATH=path/to/crashtest.list
TEST_PATH=path/to/crashtest.list make -C objdir crashtest
Keywords: regression
I don't know how that would have affected crashtest. Try backing the patch out locally?
(Assignee)

Comment 2

7 years ago
I've reverted the patch locally and it seems that it is fixing the issue but I really don't understand how that could happen :/
Weirdly, changing TEST_PATH=foo to TEST_PATH?=foo in crashtest and jstestbrowser fixes the issue...
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 3

7 years ago
Created attachment 491035 [details] [diff] [review]
Patch v1
Assignee: nobody → mounir.lamouri
Status: NEW → ASSIGNED
Attachment #491035 - Flags: review?(ted.mielczarek)
Attachment #491035 - Flags: approval2.0?
(Assignee)

Comment 4

7 years ago
CCing Kyle in case of he wants to steal the review ;)
Comment on attachment 491035 [details] [diff] [review]
Patch v1

r=me

FWIW, I'd call this NPOTB and check it in.
Attachment #491035 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Updated

7 years ago
Attachment #491035 - Flags: approval2.0?
(Assignee)

Comment 6

7 years ago
Pushed:
http://hg.mozilla.org/mozilla-central/rev/1b4d00d79ae6

Unfortunately, I still don't understand why it wasn't working (doesn't make sense to me) but if this patch fix it, that's nice :)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8

Updated

7 years ago
Duplicate of this bug: 551474
You need to log in before you can comment on or make changes to this bug.