Search results page redirects to a blank search results page after changing the language

RESOLVED DUPLICATE of bug 466895

Status

RESOLVED DUPLICATE of bug 466895
8 years ago
3 years ago

People

(Reporter: saikrishna, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

After searching for an addon and changing the language, search results page redirects to a blank search results page

Reproducible: Always

Steps to Reproduce:
1.Load AMO Next Server ( https://addons-next.allizom.org/en-US/firefox/ )
2.Type in some search term (eg:firebug) in search field and click on Go button
3.Search results page (for firebug) is displayed
(https://addons-next.allizom.org/en-US/firefox/search/?q=firebug&cat=all&lver=any&pid=1&sort=&pp=20&lup=&advanced=)
4.Now change the language from other languages drop down
Actual Results:  
Respective language UI is loaded,but the search is lost
Note: Page loads at search URL itself showing the results of blank search
(https://addons-next.allizom.org/es-ES/firefox/search/)

Expected Results:  
The search should not be lost, it just has to change the language and show the same results for firebug displayed in en-US
(Reporter)

Updated

8 years ago
Hardware: x86 → All
None of our sites' language/locale-switching functionality persists search or any other parameters, to my knowledge; I think this is invalid.

Was this from a testcase?  If so, which one?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466895
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.