Replying to emails will use 'default' address instead of original send address

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
8 years ago
7 months ago

People

(Reporter: uffie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-02-23])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.12) Gecko/20101027 Windows/Windows NT 5.1 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.15) Gecko/20101027 Thunderbird/3.0.1

Replying to emails will use 'default' address instead of original send address, which is prone to reveal other account identities by accident. Happened several times here.

Please fix soon.

Reproducible: Always

Steps to Reproduce:
1. send email with mail account 2
2. receive response mail
3. reply to received mail will auto-select DEFAULT mail address (e.g. account 1)
Actual Results:  
Sending reply mail without verification of 'from' address will always result in sending with DEFAULT mail address (e.g. account 1), thus revealing other mail accounts / identities

Expected Results:  
Sending reply mail must always result in auto-selecting the original 'from' mail address, from which the original mail was sent (e.g. account 2)
(Reporter)

Comment 1

8 years ago
Duplicate of Bug 608465
Version: unspecified → 3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608465
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

8 years ago
Whoops, sorry, but this is NOT a duplicate of 608465!

That bug obviously refers to replying to a mail in the 'sent' folder from an non-standard account directly. 

This bug, 612894, is about the odd behavior of Thunderbird, that leads to always selecting the default mail account address, when replying to INCOMING messages. Regardless, of with what (non-default) account the original mail has been sent with. 

But, unlike when creating 'new' messages, a 'reply' should by default always contain the 'from' address of the account, from which the original mail has been sent.

Should've read the other bug description more thoroughly...
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Can we get an email showing the issue ?

cause I use identities all the time. The only time it doesn't work is when I end up either in bug 608465 or bug 230247.

Do you also have your issue in -safe-mode ?

Comment 5

7 years ago
The Virtual Identity add-on is designed to help fix this, but it doesn't do a complete (or always accurate) job of it.

Comment 6

6 years ago
Reporter do you still see this problem when using recent version of
Thunderbird?
Whiteboard: [closeme 2012-02-23]
RESOLVED INCOMPLETE due to lack of response to the previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → INCOMPLETE

Comment 8

2 years ago
This bug is still alive and well in Icedove 31.7.0 debian stable.
There's even a plugin to work around it (which may not exactly be a solution):
https://addons.mozilla.org/en-US/thunderbird/addon/correct-identity/

Comment 9

7 months ago
likely a duplicate of one of these https://mzl.la/2vTGYjA
You need to log in before you can comment on or make changes to this bug.