Need warning when entering invalid data

VERIFIED DUPLICATE of bug 99404

Status

SeaMonkey
Preferences
P3
normal
VERIFIED DUPLICATE of bug 99404
18 years ago
14 years ago

People

(Reporter: Adam, Assigned: matt)

Tracking

Trunk
mozilla0.9.6
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
There needs to be some type of alert thrown up when a user inputs invalid data.
If you change the font dpi to "9t," Mozilla will drop the "t" and render fonts
at 9dpi, without ever informing the user that "t" is an invalid entry. Also, its
not very good that Mozilla just drops the "t" - if I enter "9t," I don't want
Mozilla to render any dpi other than "9t." An alert informing me that 9t will
allow me to make a decision, rather than just having Mozilla arbitrarily decide
what I meant to enter.

I'm sure this is the same for cache, history, etc. I consider this major but am
leaving it up to the discretion of somebody else to decide how important this
actually is.
(Reporter)

Comment 1

18 years ago
Clarification - It seems like a no-brainer that "t" is an invalid entry. But if
I accidentally hit the "t" instead of "6" and didn't catch it before pressing
OK, the fonts will get rendered at 9dpi (which causes a lot of problems with the
Modern skin). Mozilla should refrain from automatically changing settings
without first informing the user.
This is a pref front-end issue.
Component: Preferences: Backend → Preferences
Forgot to reassign
Assignee: dveditz → matt
Keywords: correctness

Comment 4

18 years ago
I think this bug should be replaced by one requesting a new attribute for XUL 
textfields, to ignore/allow input of particular characters (e.g. allow only 
numeric characters). It's much more pleasant to prevent the user from entering 
invalid data in the first place, than to throw up an alert telling the user how 
stupid they are.
(Reporter)

Comment 5

18 years ago
Unless somebody can think of a specific scenario where this would not be
preferable, that sounds like it should be sufficient. There might need to be
warnings for specific fields where the data entered is "correct" but not advised
(setting 9dpi, for example, as that isn't really a valid resolution for most
users), but those would need to be filed separately.

Comment 6

18 years ago
The specific case of dpi should be handled by a popup menu, with an `Other ...' 
option which leads to a separate dialog with an on-screen ruler and a slider. A 
text field would hardly be necessary.

Comment 7

17 years ago
This bug depends on bug 66163 as does the one I am dup'ing it in favor of: bug
99404.

*** This bug has been marked as a duplicate of 99404 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla0.9.6
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.