xpcshell/tests/js/jetpack/tests/unit/test_jetpack.js and chrome://mochitests/content/chrome/js/jetpack/tests/test_jetpack_crash.xul - Crash [@ IPC::Channel::set_listener]

RESOLVED FIXED

Status

()

Core
IPC
--
critical
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: Benjamin Smedberg)

Tracking

({intermittent-failure})

Trunk
x86_64
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 491361 [details]
tinderbox log excerpt (includes crash report)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1290035672.1290036819.28354.gz&fulltext=1

Rev3 Fedora 12x64 mozilla-central opt test xpcshell on 2010/11/17 15:14:32

First happened on http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=dc021bc9929f.  Since this was very recent, I don't yet know whether this is intermittent orange or perma-orange.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 12

7 years ago
Created attachment 491867 [details] [diff] [review]
Unrace, rev. 1
Attachment #491867 - Flags: review?(jones.chris.g)
(Assignee)

Updated

7 years ago
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Summary: xpcshell/tests/js/jetpack/tests/unit/test_jetpack.js - Crash [@ IPC::Channel::set_listener] → xpcshell/tests/js/jetpack/tests/unit/test_jetpack.js - Crash [@ IPC::Channel::set_listener], with "test failed (with xpcshell return code: 1)"
Comment hidden (Treeherder Robot)
Duplicate of this bug: 613623
Looks like this affects test_jetpack_crash.xul (added 2 days ago), too:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1290203331.1290206730.23287.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2010/11/19 13:48:51
s: win32-slave34
TEST-UNEXPECTED-FAIL |
chrome://mochitests/content/chrome/js/jetpack/tests/test_jetpack_crash.xul |
Exited with code -1073741819 during test run

I originally filed Bug 613623 on that one, but jdm pointed out that the stack looks like the one here. (See that bug for the full stack.)
Summary: xpcshell/tests/js/jetpack/tests/unit/test_jetpack.js - Crash [@ IPC::Channel::set_listener], with "test failed (with xpcshell return code: 1)" → xpcshell/tests/js/jetpack/tests/unit/test_jetpack.js and chrome://mochitests/content/chrome/js/jetpack/tests/test_jetpack_crash.xul - Crash [@ IPC::Channel::set_listener]
Comment hidden (Treeherder Robot)
Attachment #491867 - Flags: review?(jones.chris.g) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 27

7 years ago
http://hg.mozilla.org/mozilla-central/rev/852dd5b5c8b7
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.