dirs with ending slash in addFile() hang the progress dlog

VERIFIED DUPLICATE of bug 61346

Status

P3
normal
VERIFIED DUPLICATE of bug 61346
18 years ago
3 years ago

People

(Reporter: depman1, Assigned: dveditz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
branch and trunk builds. 2000-11-27. all platforms.
1. Go to http://jimbob/trigger3.html
2. Enter either of these in the url field:
a. http://jimbob/jars/f_addf_fileindir_source1.xpi (this passes 'dir/' into the 
jarSrc (3rd) param of addFile.
b. http://jimbob/jars/f_addf_fileindir_target2.xpi (this passes 'dir/' into the 
target (5th) param of addFile.
3. Press Trigger. Then OK the confirm dlog.
Result: Progress dlog hangs. On Windows 98, get "an unknown error has occurred 
(804b0003) in the status bar area.
Expected: No hang. Progress dlog completes.
(Reporter)

Comment 1

18 years ago
apparently this one went through even though there were problems with Bugzilla. 
bug 61346 is the active bug for this.

*** This bug has been marked as a duplicate of 61346 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.