Occasionally getting a CSS/JS-less Edit Add-on page

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
--
major
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: stephend, Assigned: cvan)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 491420 [details]
Screenshot

Setting severity to Major, since it's bad, but I can't reproduce this at will, sorry.

STR:

Sometimes, loading https://addons-next.allizom.org/z/en-US/developers/addon/7431/edit_basic/edit or a similar URL of another add-on results in a CSS-less page; I *think* it's because the GET request it sometimes missing the Minify version string?

When it fails, the request looks like this:

18:41:23.469: Network: GET https://addons-next.allizom.org/z/en-US/developers/addon/7431/edit_basic/edit [HTTP/1.1 200 OK 174ms]

The content of the page is literally <form> to </form> -- no <html>, no <head>, no <body>, etc.
(Reporter)

Comment 1

7 years ago
Created attachment 491421 [details]
Headers
(Reporter)

Updated

7 years ago
Summary: Occasionally getting a CSS-less Edit Add-on page → Occasionally getting a CSS/JS-less Edit Add-on page
(Assignee)

Comment 2

7 years ago
Fixed in commit: https://github.com/jbalogh/zamboni/commit/a22956
Assignee: nobody → cwiemeersch
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

7 years ago
Verified FIXED; although I could never make it happen *at will*, I certainly can't reproduce in all the times I've tried, since.  Thanks!
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.