Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 613124 - Make use of file readahead for reading optimized jars
: Make use of file readahead for reading optimized jars
Status: RESOLVED DUPLICATE of bug 810151
Product: Core
Classification: Components
Component: Networking: JAR (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Patrick McManus [:mcmanus]
Depends on:
Blocks: 711811
  Show dependency treegraph
Reported: 2010-11-17 20:24 PST by (dormant account)
Modified: 2013-10-28 09:36 PDT (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

windows side of things (3.77 KB, patch)
2010-11-17 20:24 PST, (dormant account)
no flags Details | Diff | Splinter Review

Description (dormant account) 2010-11-17 20:24:29 PST
Created attachment 491447 [details] [diff] [review]
windows side of things

On windows using sequential readahead results in 5-10 reduction in io waiting time over random io.
Comment 1 (dormant account) 2011-10-10 16:18:15 PDT
Something like this should be finished up with
Comment 2 Chris Peterson [:cpeterson] 2013-10-25 16:27:04 PDT
Taras: Is this 2010 patch to read jars using Windows' FILE_FLAG_SEQUENTIAL_SCAN still relevant?
Comment 3 (dormant account) 2013-10-28 09:36:04 PDT

*** This bug has been marked as a duplicate of bug 810151 ***

Note You need to log in before you can comment on or make changes to this bug.