Closed Bug 613224 Opened 9 years ago Closed 9 years ago

Documentation has outdated links in altbase.h and other files, MDN /docs/

Categories

(MailNews Core :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.3a2

People

(Reporter: sdwilsh, Unassigned)

References

Details

Attachments

(1 file)

http://developer.mozilla.org/en/docs/atlbase.h is linked to in a cofigure error, however, the page doesn't exist.  It should point to https://developer.mozilla.org/en/atlbase.h, but until we can update the configure check, we should probably try to setup a redirect.
Existing links to en/docs/* are obsolete and should have been fixed years ago; however, they're still out there and need to be redirected (they have been being redirected for years now).
Closing as we can't do 1 off redirects for all obsolete urls under /docs.

As @sheppy said, /docs is now serviced by a Django based app.

Feel free to reopen and move to a component/product appropriate for fixing the  config error.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
If urls in configure.in are out of date, just change them.
(In reply to comment #3)
> If urls in configure.in are out of date, just change them.
I'm not sure when I'm next checking in, but if someone else wants to fix it, they should feel free to.  This was an issue that someone on freenode was hitting, which is why I filed the bug.
Status: RESOLVED → REOPENED
Component: Website → Build Config
Product: Mozilla Developer Network → Core
QA Contact: website → build-config
Resolution: FIXED → ---
Version: unspecified → Trunk
Sucks that we can't keep consistent URLs on our own docs site, makes keeping in-tree documentation links hard!
ozten, why can't we use a django path or rewrite rule to rewrite all the obsolete links? There are links all over the internet that would stop working, and this is a pretty big deal that we should solve. There are currently at least 25 links in our codebase alone:

http://mxr.mozilla.org/mozilla-central/search?string=developer.mozilla.org%2Fen%2Fdocs

Considering that we were the standard reference sites for years, and asked people to link to our docs with the old URL scheme, I think we have a responsibility to keep the links working.
Component: Build Config → Docs Platform
Product: Core → Mozilla Developer Network
QA Contact: build-config → docs-platform
Version: Trunk → MDN
Make that 52...
(In reply to comment #6)
per comment #1 all documentation under docs has been obsolete for years and is not being maintained by the community. I don't think we want people linking to these pages.

We already have a Rube Goldberg inspired set of Apache configs for the current setup and every additional rule slows down the site and increases maintenance burdens.
(In reply to comment #8)
> (In reply to comment #6)
> per comment #1 all documentation under docs has been obsolete for years and is
> not being maintained by the community. I don't think we want people linking to
> these pages.
> 
> We already have a Rube Goldberg inspired set of Apache configs for the current
> setup and every additional rule slows down the site and increases maintenance
> burdens.

Er, what?  AFAICT all that has changed is that links that were dev.m.o/en/docs/Foo are now dev.m.o/en/Foo.  I'm not sure what that has to do with docs  being obsolete for years ...
Yeah, we expect d.m.o/en/docs/Foo to end up redirecting to dmo/en/Foo.
What otzen means is that the dev.m.o/en/docs/foo links have been obsolete for years. We got rid of the "/docs/" part a good three years ago, so the only change at this time is that we stopped redirecting them.
Yes, but the links still exist. A quick google search found thousands of links from old newsgroup posts to dmo/en/docs/Build_Documentation. We should keep these working through site redesigns basically permanently.
I agree, except that we need to be fixing those links in our code, which is what this bug is about.
Attached is a patch for comm-central's /docs/ links.

Who can I put as a reviewer (who could also commit for me?)

Thanks.
Comment on attachment 492383 [details] [diff] [review]
Fixing broken /docs links

r=me, I'll push later. I did not verify that this was all the links with /docs/ but I did verify this patch is ok.
Attachment #492383 - Flags: review?(bugspam.Callek) → review+
Would have been nice if the checkin comment, perhaps even the bug summary would have described better what the checkin actually does. But what's done is done.
Component: Docs Platform → General
OS: Windows 7 → All
Product: Mozilla Developer Network → Core
QA Contact: docs-platform → general
Hardware: x86 → All
Summary: Bad link for atlbase.h → Documentation has outdated links in altbase.h and other files, MDN /docs/
Version: MDN → Trunk
Duplicate of this bug: 614504
Lets use Bug 614504 to fix m-c.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Component: General → Build Config
Product: Core → MailNews Core
QA Contact: general → build-config
Target Milestone: --- → Thunderbird 3.3a2
Can we backport this to comm-1.9.2 ? This would better keep calendar/locales files in sync at the moment.
You need to log in before you can comment on or make changes to this bug.