Closed Bug 613280 Opened 9 years ago Closed 9 years ago

Cannot copy result text in console

Categories

(DevTools :: General, defect, P2)

defect

Tracking

(blocking2.0 betaN+)

VERIFIED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: jbalogh, Assigned: msucan)

References

Details

(Whiteboard: [softblocker][to be fixed by 605621][fx4-fixed-bugday])

Attachments

(1 file, 2 obsolete files)

The result of js expressions are clickable objects, and I can't find a way to copy the text.  Right-click shows the context menu for the whole console. If I try to start a selection before the result it's still ignored.

For example, 2 cannot be selected here:

> 1 + 1
2
Assignee: nobody → mihai.sucan
Blocks: devtools4
Is this a regression from bug 587617?
Florin: bug 587617 fixed an issue with text selection and copying, on Linux. I doubt it caused this regression.
mass change: filter on PRIORITYSETTING
Priority: -- → P2
Attached patch proposed patch (obsolete) — Splinter Review
Proposed patch. This fixes a minor style issue that prevents users from selecting jsterm output and copying the text. I believe this is a regression caused by some previous work on jsterm code.

Included is a test case that checks for this specific issue.
Attachment #493512 - Flags: feedback?(pwalton)
Asking for blocking2.0+: this bug affects all users of the Web Console, on all operating systems. An important functionality (select > copy) is not working as expected.
Status: NEW → ASSIGNED
blocking2.0: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [patchclean:1127]
Comment on attachment 493512 [details] [diff] [review]
proposed patch

>diff --git a/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_613280_jsterm_copy.js b/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_613280_jsterm_copy.js
>new file mode 100644
>--- /dev/null
>+++ b/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_613280_jsterm_copy.js
>+    make_selection();
>+  }
>+  else {
>+    make_selection();
>+  }

Move make_selection after the if statement perhaps?

The patch doesn't apply in the makefile, but looks good to me otherwise. f+!
Attachment #493512 - Flags: feedback?(pwalton) → feedback+
Attached patch updated patch (obsolete) — Splinter Review
Updated patch based on your feedback. Yeah, I forgot to do that. The test started from a different iteration. Thanks for the feedback+!

Asking for review.
Attachment #493512 - Attachment is obsolete: true
Attachment #494471 - Flags: review?(dolske)
Whiteboard: [patchclean:1127] → [patchclean:1201]
blocking2.0: ? → betaN+
Attachment #494471 - Flags: review?(dolske) → review+
The current situation here:

- this patch no longer applies cleanly / works as intended, because the code changed a lot with the checkin of part 1 from bug 605621.

- this bug is going to (should) be fixed by part 2 from bug 605621.

- currently, part 1 landed, but not part 2, which means users cannot copy anything from the Web Console, not just jsterm results. The situation is now worse than initially reported in this bug.

- this patch should only hold the mochitest, once part 2 of bug 605621 lands.

Marking 605621 as a dependency.
Depends on: 605621
Whiteboard: [patchclean:1201] → [patchclean:1201][hardblocker]
Whiteboard: [patchclean:1201][hardblocker] → [patchclean:1201][hardblocker][to be fixed by 605621]
Whiteboard: [patchclean:1201][hardblocker][to be fixed by 605621] → [hardblocker][to be fixed by 605621]
should be fixed by landing of bug 605621.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
reopening. Looks like there's a test to land with this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [hardblocker][to be fixed by 605621] → [softblocker][to be fixed by 605621]
Removing hardblocker since this is now fixed, making this bug tests-only.
Attached patch mochitest onlySplinter Review
Updated the patch. It only holds the mochitest now, rebased to work with the latest Web Console changes.
Attachment #494471 - Attachment is obsolete: true
Attachment #505438 - Flags: feedback?
Attachment #505438 - Flags: feedback? → feedback?(rcampbell)
Comment on attachment 505438 [details] [diff] [review]
mochitest only

looks good.
Attachment #505438 - Flags: feedback?(rcampbell) → feedback+
Keywords: checkin-needed
Whiteboard: [softblocker][to be fixed by 605621] → [softblocker][to be fixed by 605621][checkin-needed]
marking fixed. Thanks for the checkin.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Whiteboard: [softblocker][to be fixed by 605621][checkin-needed] → [softblocker][to be fixed by 605621]
Reproduced with Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101123 Firefox/4.0b8pre

Verified fixed with 4.0 beta 11 build 3 — Mozilla/5.0 (X11; Linux i686; rv:2.0b11) Gecko/20100101 Firefox/4.0b11 (the timestamp and the number are copied)
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker][to be fixed by 605621] → [softblocker][to be fixed by 605621][fx4-fixed-bugday]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.