[RFE] Table, Delete, Column should be disabled if columns not selected

VERIFIED FIXED in Future

Status

()

Core
Editor
P4
enhancement
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Chuck R., Assigned: Charles Manske)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)
BuildID:    2000112204

The menu item in the Composer, Table, Columns, Delete should be disabled if the 
user does not choose any columns in a table. 

Reproducible: Always
Steps to Reproduce:
1. I made a 3row x 10col table.
2. I used control to select 3 columns of *one* row (the first row), in the 
middle (like cols 3-6)
3. I did the menu items Table, Delete, Columns. 
4. Mozilla did not do anything because I selected only a single row, not all the 
rows for the columns.


Expected Results:  The user is required to select columns in order to do Table, 
Delete, Columns. If they have not selected columns, the menu item Table, Delete, 
Columns should be disabled. 

The same goes for other items on Table, Delete. If the user does not select a 
whole row, Table, Delete, Row should be disabled. 


Disable menu/toolbar items that do nothing if the user hasn't done the required 
steps (like selecting something).

Comment 1

18 years ago
assign to cmanske, setting to future, adding helpwanted
Severity: minor → trivial
Keywords: helpwanted
Priority: P3 → P4
Target Milestone: --- → Future

Comment 2

18 years ago
Marking NEW so someone will look at it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Table, Delete, Column should be disabled if columns not selected → [RFE] Table, Delete, Column should be disabled if columns not selected

Comment 3

17 years ago
-->cmanske
Assignee: beppe → cmanske
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Comment 4

17 years ago
I disagree. Since selecting columns is not easy, being able to delete the column
where your caret is in is very usefull.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 5

17 years ago
Actually, reading the first desciption more carefully, we actually do exactly
what is requested.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 6

17 years ago
We can do what was requested: select any number of cells, and use "delete row or
column" to delete multiple rows/columns.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
Verified in 8-28 Build
Status: RESOLVED → VERIFIED

Comment 8

16 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: trivial → enhancement
You need to log in before you can comment on or make changes to this bug.